summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/lziprecover/Manifest1
-rw-r--r--app-arch/lziprecover/lziprecover-1.23.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lziprecover/Manifest b/app-arch/lziprecover/Manifest
index 936c9384093d..e1928d7be13e 100644
--- a/app-arch/lziprecover/Manifest
+++ b/app-arch/lziprecover/Manifest
@@ -1 +1,2 @@
DIST lziprecover-1.22.tar.gz 152840 BLAKE2B c6c5ca0bcb0309539d48c89a1259c5d1d9b47372a92935f762daa428a9e66d6ab0b0a2ac956b70e15824d699c7de0d92e92f0c7ff68ea091599754082771b928 SHA512 5fa209f6a80314ba7db45effc2546be660b6a31133570abf2e37a4d570910757fc4241e2496e63a95fadb66cffbca59976a8568659f4e8562baeb16517599e96
+DIST lziprecover-1.23.tar.gz 156147 BLAKE2B 71a210c7143ff6f0f8b9cce7d5a1b6f681f8331fb971fa2836dfd04ad50e732ab595a415a9b8a3020c70c884c7e7fce5c605e63e0f28ea94f2de9d5447199a83 SHA512 9f2d40311f901c2c00fa6b106a2363dfcd7b6c73ae86282733d7c3451237ee30f6d5cce035ab5ba63300eea637eeb3ac5db7e7571bdef1bef259b801b10f1c7a
diff --git a/app-arch/lziprecover/lziprecover-1.23.ebuild b/app-arch/lziprecover/lziprecover-1.23.ebuild
new file mode 100644
index 000000000000..cd4f742fd89c
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.23.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for lzip compressed files"
+HOMEPAGE="https://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}