summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/wf-config/wf-config-0.7.1-r1.ebuild13
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild13
2 files changed, 24 insertions, 2 deletions
diff --git a/gui-libs/wf-config/wf-config-0.7.1-r1.ebuild b/gui-libs/wf-config/wf-config-0.7.1-r1.ebuild
index c663a20684e4..a223d4b9907c 100644
--- a/gui-libs/wf-config/wf-config-0.7.1-r1.ebuild
+++ b/gui-libs/wf-config/wf-config-0.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/libevdev
@@ -28,4 +30,13 @@ RDEPEND="${DEPEND}"
BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
+ test? ( dev-cpp/doctest )
"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index 7ceb2c95adb3..ae9b12db688b 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/libevdev
@@ -28,4 +30,13 @@ RDEPEND="${DEPEND}"
BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
+ test? ( dev-cpp/doctest )
"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ )
+
+ meson_src_configure
+}