summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/polarssl/Manifest1
-rw-r--r--net-libs/polarssl/files/polarssl-1.3.9-respect-cflags.patch15
-rw-r--r--net-libs/polarssl/metadata.xml18
-rw-r--r--net-libs/polarssl/polarssl-1.3.9-r1.ebuild95
-rw-r--r--net-libs/polarssl/polarssl-1.3.9.ebuild92
-rw-r--r--profiles/default/linux/package.use.mask4
-rw-r--r--profiles/package.mask6
7 files changed, 0 insertions, 231 deletions
diff --git a/net-libs/polarssl/Manifest b/net-libs/polarssl/Manifest
deleted file mode 100644
index 6561d6e2f770..000000000000
--- a/net-libs/polarssl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST polarssl-1.3.9-gpl.tgz 1741396 BLAKE2B 0eb717174bc314660b8abcdd9509603edd905ef835a96c2f0a7e3f52f90f3ca491833d489752e72d43217ae54bd9dd319d67925c3193988183a934085b2a553d SHA512 e8958f834fd80ac996ac58152a0a5d4e31449e8b7b79ee6daac6f45bed60c5c5ad31f84b211d5e36ad0d6c82a742841e986a738735af048c286bce0e8fe4d62d
diff --git a/net-libs/polarssl/files/polarssl-1.3.9-respect-cflags.patch b/net-libs/polarssl/files/polarssl-1.3.9-respect-cflags.patch
deleted file mode 100644
index 45dffd53041c..000000000000
--- a/net-libs/polarssl/files/polarssl-1.3.9-respect-cflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sat Oct 25 17:12:43 UTC 2014
-Subject: respect system cflags
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -4,7 +4,7 @@
- string(REGEX MATCH "Clang" CMAKE_COMPILER_IS_CLANG "${CMAKE_C_COMPILER_ID}")
-
- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_C_FLAGS "-Wall -Wextra -W -Wdeclaration-after-statement -Wlogical-op -Wwrite-strings")
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -W -Wdeclaration-after-statement -Wlogical-op -Wwrite-strings")
- set(CMAKE_C_FLAGS_RELEASE "-O2")
- set(CMAKE_C_FLAGS_DEBUG "-g3 -O0")
- set(CMAKE_C_FLAGS_COVERAGE "-g3 -O0 --coverage")
diff --git a/net-libs/polarssl/metadata.xml b/net-libs/polarssl/metadata.xml
deleted file mode 100644
index eafc157bbafb..000000000000
--- a/net-libs/polarssl/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>tommy@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
- The aim of the PolarSSL project is to provide a quality, open-source
- cryptographic library written in C and targeted at embedded systems.
- </longdescription>
- <use>
- <flag name="havege">Enable the HAVEGE random generator.
- Warning: the HAVEGE random generator is not suitable for
- virtualized environments
- </flag>
- <flag name="programs">Build PolarSSL programs</flag>
- </use>
-</pkgmetadata>
diff --git a/net-libs/polarssl/polarssl-1.3.9-r1.ebuild b/net-libs/polarssl/polarssl-1.3.9-r1.ebuild
deleted file mode 100644
index 01f8abbeec11..000000000000
--- a/net-libs/polarssl/polarssl-1.3.9-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib cmake-utils multilib-minimal
-
-DESCRIPTION="Cryptographic library for embedded systems"
-HOMEPAGE="http://polarssl.org/"
-SRC_URI="http://polarssl.org/download/${P}-gpl.tgz"
-
-LICENSE="GPL-2"
-SLOT="0/7"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="doc havege libressl programs cpu_flags_x86_sse2 static-libs test threads zlib"
-
-RDEPEND="
- programs? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen media-gfx/graphviz )
- test? ( dev-lang/perl )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch )
-
-enable_polarssl_option() {
- local myopt="$@"
- # check that config.h syntax is the same at version bump
- sed -i \
- -e "s://#define ${myopt}:#define ${myopt}:" \
- include/polarssl/config.h || die
-}
-
-src_prepare() {
- use cpu_flags_x86_sse2 && enable_polarssl_option POLARSSL_HAVE_SSE2
- use zlib && enable_polarssl_option POLARSSL_ZLIB_SUPPORT
- use havege && enable_polarssl_option POLARSSL_HAVEGE_C
- use threads && enable_polarssl_option POLARSSL_THREADING_C
- use threads && enable_polarssl_option POLARSSL_THREADING_PTHREAD
-
- cmake-utils_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- $(multilib_is_native_abi && cmake-utils_use_enable programs PROGRAMS \
- || echo -DENABLE_PROGRAMS=OFF)
- $(cmake-utils_use_enable zlib ZLIB_SUPPORT)
- $(cmake-utils_use_use static-libs STATIC_POLARSSL_LIBRARY)
- $(cmake-utils_use_enable test TESTING)
- -DUSE_SHARED_POLARSSL_LIBRARY=ON
- -DINSTALL_POLARSSL_HEADERS=ON
- -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- use doc && multilib_is_native_abi && emake apidoc
-}
-
-multilib_src_test() {
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${BUILD_DIR}/library" \
- cmake-utils_src_test
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- use doc && dohtml -r apidoc
-
- if use programs ; then
- # avoid file collisions with sys-apps/coreutils
- local p e
- for p in "${ED%/}"/usr/bin/* ; do
- if [[ -x "${p}" && ! -d "${p}" ]] ; then
- mv "${p}" "${ED%/}"/usr/bin/polarssl_${p##*/} || die
- fi
- done
- for e in aes hash pkey ssl test ; do
- docinto "${e}"
- dodoc programs/"${e}"/*.c
- dodoc programs/"${e}"/*.txt
- done
- fi
-}
diff --git a/net-libs/polarssl/polarssl-1.3.9.ebuild b/net-libs/polarssl/polarssl-1.3.9.ebuild
deleted file mode 100644
index 6dce83e4878f..000000000000
--- a/net-libs/polarssl/polarssl-1.3.9.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib cmake-utils multilib-minimal
-
-DESCRIPTION="Cryptographic library for embedded systems"
-HOMEPAGE="http://polarssl.org/"
-SRC_URI="http://polarssl.org/download/${P}-gpl.tgz"
-
-LICENSE="GPL-2"
-SLOT="0/7"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="doc havege programs cpu_flags_x86_sse2 static-libs test threads zlib"
-
-RDEPEND="
- programs? ( dev-libs/openssl:0 )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen media-gfx/graphviz )
- test? ( dev-lang/perl )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch )
-
-enable_polarssl_option() {
- local myopt="$@"
- # check that config.h syntax is the same at version bump
- sed -i \
- -e "s://#define ${myopt}:#define ${myopt}:" \
- include/polarssl/config.h || die
-}
-
-src_prepare() {
- use cpu_flags_x86_sse2 && enable_polarssl_option POLARSSL_HAVE_SSE2
- use zlib && enable_polarssl_option POLARSSL_ZLIB_SUPPORT
- use havege && enable_polarssl_option POLARSSL_HAVEGE_C
- use threads && enable_polarssl_option POLARSSL_THREADING_C
- use threads && enable_polarssl_option POLARSSL_THREADING_PTHREAD
-
- cmake-utils_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- $(multilib_is_native_abi && cmake-utils_use_enable programs PROGRAMS \
- || echo -DENABLE_PROGRAMS=OFF)
- $(cmake-utils_use_enable zlib ZLIB_SUPPORT)
- $(cmake-utils_use_use static-libs STATIC_POLARSSL_LIBRARY)
- $(cmake-utils_use_enable test TESTING)
- -DUSE_SHARED_POLARSSL_LIBRARY=ON
- -DINSTALL_POLARSSL_HEADERS=ON
- -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- use doc && multilib_is_native_abi && emake apidoc
-}
-
-multilib_src_test() {
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${BUILD_DIR}/library" \
- cmake-utils_src_test
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- use doc && dohtml -r apidoc
-
- if use programs ; then
- # avoid file collisions with sys-apps/coreutils
- local p e
- for p in "${ED%/}"/usr/bin/* ; do
- if [[ -x "${p}" && ! -d "${p}" ]] ; then
- mv "${p}" "${ED%/}"/usr/bin/polarssl_${p##*/} || die
- fi
- done
- for e in aes hash pkey ssl test ; do
- docinto "${e}"
- dodoc programs/"${e}"/*.c
- dodoc programs/"${e}"/*.txt
- done
- fi
-}
diff --git a/profiles/default/linux/package.use.mask b/profiles/default/linux/package.use.mask
index 0a6667cd9dce..8060b8e26b79 100644
--- a/profiles/default/linux/package.use.mask
+++ b/profiles/default/linux/package.use.mask
@@ -20,10 +20,6 @@ net-dns/bind seccomp
# media-libs/libomxil-bellagio keyworded on amd64/x86
media-libs/mesa openmax
-# Thomas Sachau <tommy@gentoo.org> (25 Dez 2013)
-# mask frost USE flag, broken with >=net-libs/polarssl-1.3.0, bug 489256
-net-p2p/fms frost
-
# Diego Elio Pettenò (27 Aug 2012)
# The libpci access is only used for linux.
net-analyzer/net-snmp -pci
diff --git a/profiles/package.mask b/profiles/package.mask
index 5629470181d3..5a0f27b387a1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -725,12 +725,6 @@ dev-python/pydb
# Dead upstream, unclear license. Removal in 30 days.
dev-python/pygui
-# Thomas Deutschmann <whissi@gentoo.org> (14 Dec 2017)
-# Unpatched security vulnerability per bug #537108
-# Removal in 30 days. Please migrate to net-libs/mbedtls if you have
-# not done yet.
-net-libs/polarssl
-
# Patrice Clement <monsieurp@gentoo.org> (12 Dec 2017)
# Masked due to a hard dependency on an ancient versions of dev-libs/msgpack
# (<0.6) that have been punted from the tree.