summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/combined_robot_hw_tests/Manifest1
-rw-r--r--dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/combined_robot_hw_tests/Manifest b/dev-ros/combined_robot_hw_tests/Manifest
index 11f89d506db6..d96e00d8eab8 100644
--- a/dev-ros/combined_robot_hw_tests/Manifest
+++ b/dev-ros/combined_robot_hw_tests/Manifest
@@ -1,2 +1,3 @@
DIST ros_control-0.13.0.tar.gz 651216 BLAKE2B 88555cda44d53ddc752260591423ff9d2ddb714bd4b394704f980e55f6f039348e26ba4aef9575da995de35218527969ca77fc613eec66fe1ff276b4908924eb SHA512 877ccde854e060424f2f2ff14e504bd6d2e679ff8154b8b5be2469aac40bee9bb3c15c15ca4dea6b4a956fb38be7ea34f6bca26854d541dd840331b3f2c7771b
DIST ros_control-0.14.0.tar.gz 653901 BLAKE2B 285c936c415fbbd85fc3acfbdaa5192ee4523f14baa6c7a82c1c5cd5c46e872a1425ffec185045c9fc13d653a7182f29bd4cb4d66fdb94c5471c757c0fc2bbd3 SHA512 653be6c629c07cd7a6a27886591c71814c97e8f8d4273823e51bb80dc4875fb992819863ae15debaa4171a26244c3e07c412d15e8fced54e56cee8122d417e7e
+DIST ros_control-0.14.1.tar.gz 655028 BLAKE2B 86bdce47b947fc4f9b8be9c791ba4247240b81e391bb3f5916b26ff67256c928ea4c68d46ac3ffbe2ddb4f3b746769799bbc6617ae7822618f47770b55a09f15 SHA512 c668e589361084e51359bff2af055978cfd73c99fd33ae51962a7cefa7c6fd5a7027c0b2e5ca0c045a602b33b8037d587f9b4d958eea8b2f4199bff1e4016689
diff --git a/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.1.ebuild b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.1.ebuild
new file mode 100644
index 000000000000..e23c205a4524
--- /dev/null
+++ b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/combined_robot_hw
+ dev-ros/controller_manager
+ dev-ros/controller_manager_tests
+ dev-ros/hardware_interface
+ dev-ros/roscpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"