summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-engines/odamex/Manifest1
-rw-r--r--games-engines/odamex/files/odamex-0.8.1-SearchDir.patch11
-rw-r--r--games-engines/odamex/files/odamex-0.8.2-Fix-odamex.wad-build-flow.patch71
-rw-r--r--games-engines/odamex/files/odamex-0.8.2-Remove-duplicate-build-rule-for-odamex.wad.patch26
-rw-r--r--games-engines/odamex/odamex-0.8.2.ebuild77
5 files changed, 0 insertions, 186 deletions
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
index cd2dcf02a554..70aeb43694ac 100644
--- a/games-engines/odamex/Manifest
+++ b/games-engines/odamex/Manifest
@@ -1,2 +1 @@
DIST odamex-0.8.3.tar.bz2 8532510 BLAKE2B 751d65dfe07a4c4c0cb5ff360e76a1291cf4ba289c459f15a0c277aca4d15b1e0989e1606cdc4e0f0bec56d6ae437027046302f5c55efb3b835a42df512fb18f SHA512 01a875973d43c87dde7953464e0e3c37fa088b00b6cc0ecbef1a8b3b9a87257ab24ef4e3c224ebcbc0e38cd3139c7adc56b12a03ae2528b66d6498bb8d84d720
-DIST odamex-src-0.8.2.tar.bz2 8502115 BLAKE2B bf4acaea1c9ce81966886bdfef35d361f84dab02e32ec4fd11fe8d250b76c6ca86c0b2870f38382961949713059a2944eea50c6f4d05a41411799386ab3acc64 SHA512 bb3e2427ede7267afce8bb2b852eed3f8d2ed9cf17c5b15a264d6821d170c49dccea06ea0742d9dc7cfe42518701342572689b57ec6712f4b818bd0e25b436c8
diff --git a/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch b/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch
deleted file mode 100644
index 70bd476eb3f2..000000000000
--- a/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur a/common/d_main.cpp b/common/d_main.cpp
---- a/common/d_main.cpp 2019-07-22 19:11:28.000000000 +0100
-+++ b/common/d_main.cpp 2019-09-09 22:57:47.624246017 +0100
-@@ -459,6 +459,7 @@
- D_AddSearchDir(dirs, INSTALL_PREFIX "/" INSTALL_DATADIR "/games/odamex", separator);
- #endif
-
-+ D_AddSearchDir(dirs, "/usr/share/doom", separator);
- D_AddSearchDir(dirs, "/usr/share/games/doom", separator);
- D_AddSearchDir(dirs, "/usr/local/share/games/doom", separator);
- D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
diff --git a/games-engines/odamex/files/odamex-0.8.2-Fix-odamex.wad-build-flow.patch b/games-engines/odamex/files/odamex-0.8.2-Fix-odamex.wad-build-flow.patch
deleted file mode 100644
index e90617c38ea7..000000000000
--- a/games-engines/odamex/files/odamex-0.8.2-Fix-odamex.wad-build-flow.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 03581f45a3563d3d79075fe0e85e6fb52e864b76 Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Sat, 4 Apr 2020 22:38:26 -0400
-Subject: [PATCH] Fix odamex.wad build flow
-
-The odamex.wad file should be built in the proper build directory;
-building in the source tree confuses CMake and causes it to attempt to
-rebuild a second time. This patch also removes odawad dependency for the
-Odamex client and server executables.
----
- wad/CMakeLists.txt | 40 ++++++++++++++++++++++------------------
- 1 file changed, 22 insertions(+), 18 deletions(-)
-
-diff --git a/wad/CMakeLists.txt b/wad/CMakeLists.txt
-index c09b0d1a..349ce0df 100644
---- a/wad/CMakeLists.txt
-+++ b/wad/CMakeLists.txt
-@@ -4,28 +4,32 @@ find_program(DEUTEX deutex)
- if(DEUTEX)
- message("Found DeuTex: ${DEUTEX}")
-
-- file(REMOVE odamex.wad)
-- add_custom_command(OUTPUT odamex.wad
-- COMMAND ${DEUTEX} -rgb 0 255 255 -doom2 bootstrap -build wadinfo.txt odamex.wad
-+ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
-+ COMMAND ${DEUTEX} -rgb 0 255 255 -doom2 bootstrap -build wadinfo.txt ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-+ BYPRODUCTS ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
- VERBATIM)
-
-- add_custom_target(odawad DEPENDS odamex.wad)
-+ add_custom_target(odawad ALL
-+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad)
-
-- if(BUILD_CLIENT)
-- add_dependencies(odamex odawad)
-+ if(WIN32)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
-+ DESTINATION .
-+ COMPONENT common)
-+ else()
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex
-+ COMPONENT common)
- endif()
-- if(BUILD_SERVER)
-- add_dependencies(odasrv odawad)
-- endif()
--endif()
--
--if(WIN32)
-- install(FILES odamex.wad
-- DESTINATION .
-- COMPONENT common)
- else()
-- install(FILES odamex.wad
-- DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex
-- COMPONENT common)
-+ if(WIN32)
-+ install(FILES odamex.wad
-+ DESTINATION .
-+ COMPONENT common)
-+ else()
-+ install(FILES odamex.wad
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex
-+ COMPONENT common)
-+ endif()
- endif()
---
-2.26.0
-
diff --git a/games-engines/odamex/files/odamex-0.8.2-Remove-duplicate-build-rule-for-odamex.wad.patch b/games-engines/odamex/files/odamex-0.8.2-Remove-duplicate-build-rule-for-odamex.wad.patch
deleted file mode 100644
index 1b1bcf55d9e6..000000000000
--- a/games-engines/odamex/files/odamex-0.8.2-Remove-duplicate-build-rule-for-odamex.wad.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 2d80f79770f43d19e1af2c7b04a41078b860a46a Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Wed, 8 Apr 2020 11:47:45 -0400
-Subject: [PATCH] Remove duplicate build rule for odamex.wad
-
-The odamex.wad file shouldn't be listed in BYPRODUCTS because it's
-already listed as the OUTPUT of the add_custom_command.
----
- wad/CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/wad/CMakeLists.txt b/wad/CMakeLists.txt
-index 349ce0df..7b948ea3 100644
---- a/wad/CMakeLists.txt
-+++ b/wad/CMakeLists.txt
-@@ -7,7 +7,6 @@ if(DEUTEX)
- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
- COMMAND ${DEUTEX} -rgb 0 255 255 -doom2 bootstrap -build wadinfo.txt ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-- BYPRODUCTS ${CMAKE_CURRENT_BINARY_DIR}/odamex.wad
- VERBATIM)
-
- add_custom_target(odawad ALL
---
-2.26.0
-
diff --git a/games-engines/odamex/odamex-0.8.2.ebuild b/games-engines/odamex/odamex-0.8.2.ebuild
deleted file mode 100644
index 572889edd825..000000000000
--- a/games-engines/odamex/odamex-0.8.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WX_GTK_VER="3.0-gtk3"
-inherit cmake desktop prefix wxwidgets xdg
-
-DESCRIPTION="Online multiplayer free software engine for DOOM"
-HOMEPAGE="https://odamex.net/"
-SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${PN}-src-${PV}.tar.bz2"
-
-LICENSE="GPL-2+ MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+client master +odalaunch portmidi server upnp X"
-REQUIRED_USE="|| ( client master server )"
-
-RDEPEND="
- client? (
- media-libs/libpng:0=
- media-libs/libsdl2[joystick,sound,video]
- media-libs/sdl2-mixer
- odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- portmidi? ( media-libs/portmidi )
- X? ( x11-libs/libX11 )
- )
- server? (
- upnp? ( net-libs/miniupnpc:= )
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="games-util/deutex"
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/odamex-0.8.1-miniupnpc.patch
- "${FILESDIR}"/odamex-0.8.1-SearchDir.patch
- "${FILESDIR}"/odamex-0.8.2-Fix-odamex.wad-build-flow.patch
- "${FILESDIR}"/odamex-0.8.2-Remove-duplicate-build-rule-for-odamex.wad.patch
-)
-
-src_prepare() {
- rm -r libraries/libminiupnpc wad/odamex.wad || die
- hprefixify common/d_main.cpp
-
- use odalaunch && setup-wxwidgets
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CLIENT=$(usex client)
- -DBUILD_MASTER=$(usex master)
- -DBUILD_ODALAUNCH=$(usex odalaunch)
- -DBUILD_SERVER=$(usex server)
- -DENABLE_PORTMIDI=$(usex portmidi)
- -DUSE_MINIUPNP=$(usex upnp)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- if use client ; then
- newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
- make_desktop_entry "${PN}" "Odamex"
-
- if use odalaunch ; then
- newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
- make_desktop_entry odalaunch "Odamex Launcher" odalaunch
- fi
- fi
-
- cmake_src_install
-}