summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.10.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index eb00e43405e5..92883f94da0c 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,4 @@
+DIST libinput-1.10.0.tar.xz 491444 BLAKE2B bd7f4a68cd1ebc981cb16f402c8ea6a7bd99d7bbf289fe07923400a5bf9e259b3726c5c1765d5e31fe09b95cf9eadc88769c578d6be0f2fee4c12455d44d6d70 SHA512 173f72f454c534dee755b6121c4577900ae9b8a129ac41de69410c3195950a6d149d6148892c4976f013eeabca66117d53fa67e352cc005960863a5576696928
DIST libinput-1.7.3.tar.xz 922464 BLAKE2B fa38675905af55931676c22d9e4d56befbb055fba56ba13c61a1917050bc1eb62bcfe1d078b478047006d4c0d06d83186d0d6739cbf9dc49acce487ccb0b7e3a SHA512 2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b
DIST libinput-1.8.3.tar.xz 941832 BLAKE2B cf6464d68387cca23d0f70eaceeec8b453c53f1cac22892722d48983788b43a136617c62ad39c8d435bbf07c0cb9cd720250ea91e31f10526acd5147b1d78237 SHA512 88006d217e3507858fa6b9ac1f25c267255fb51d1bcf1208d2afd423bf2a9292944bc5526ea91f27fad3ff04c2f9f43ab3aa25fd9fb7ace1231ecd33ddf18de6
DIST libinput-1.9.4.tar.xz 472636 BLAKE2B 692a23047cb0b54d14763b34ce3ce1414101d0097dce10d237ec32a67f29c31cbf2928681084f7561e072e555c932f0e3bc54cfb0ecbcdd0d823426806e357b6 SHA512 302f9497ea9ffb2163c643e9ca2f0a773ea141f6fe0a3aa3d8e86eb11a5d11e75d858b1e679ebfd3f913c645beac059cfd356b37c4ea17a8853068f79a740a4b
diff --git a/dev-libs/libinput/libinput-1.10.0.ebuild b/dev-libs/libinput/libinput-1.10.0.ebuild
new file mode 100644
index 000000000000..44cea37f06a6
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}