summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/obs-studio/obs-studio-30.0.2.ebuild5
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/media-video/obs-studio/obs-studio-30.0.2.ebuild b/media-video/obs-studio/obs-studio-30.0.2.ebuild
index 55a19f2112ae..0b7c6e1502c3 100644
--- a/media-video/obs-studio/obs-studio-30.0.2.ebuild
+++ b/media-video/obs-studio/obs-studio-30.0.2.ebuild
@@ -38,8 +38,9 @@ LICENSE="Boost-1.0 GPL-2+ MIT Unlicense"
SLOT="0"
IUSE="
+alsa browser decklink fdk jack lua mpegts nvenc pipewire pulseaudio
- python qsv speex +ssl truetype v4l vlc wayland websocket
+ python qsv speex +ssl test truetype v4l vlc wayland websocket
"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
browser? ( || ( alsa pulseaudio ) )
lua? ( ${LUA_REQUIRED_USE} )
@@ -114,6 +115,7 @@ DEPEND="
qsv? ( media-libs/oneVPL )
speex? ( media-libs/speexdsp )
ssl? ( net-libs/mbedtls:= )
+ test? ( dev-util/cmocka )
truetype? (
media-libs/fontconfig
media-libs/freetype
@@ -194,6 +196,7 @@ src_configure() {
-DENABLE_RNNOISE=ON
-DENABLE_RTMPS=$(usex ssl ON OFF) # Needed for bug 880861
-DENABLE_SPEEXDSP=$(usex speex)
+ -DENABLE_UNIT_TESTS=$(usex test)
-DENABLE_V4L2=$(usex v4l)
-DENABLE_VLC=$(usex vlc)
-DENABLE_VST=ON
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 1a062e5a1f6a..872dd6a06a66 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -38,8 +38,9 @@ LICENSE="Boost-1.0 GPL-2+ MIT Unlicense"
SLOT="0"
IUSE="
+alsa browser decklink fdk jack lua mpegts nvenc pipewire pulseaudio
- python qsv speex +ssl truetype v4l vlc wayland websocket
+ python qsv speex +ssl test truetype v4l vlc wayland websocket
"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
browser? ( || ( alsa pulseaudio ) )
lua? ( ${LUA_REQUIRED_USE} )
@@ -114,6 +115,7 @@ DEPEND="
qsv? ( media-libs/oneVPL )
speex? ( media-libs/speexdsp )
ssl? ( net-libs/mbedtls:= )
+ test? ( dev-util/cmocka )
truetype? (
media-libs/fontconfig
media-libs/freetype
@@ -194,6 +196,7 @@ src_configure() {
-DENABLE_RNNOISE=ON
-DENABLE_RTMPS=$(usex ssl ON OFF) # Needed for bug 880861
-DENABLE_SPEEXDSP=$(usex speex)
+ -DENABLE_UNIT_TESTS=$(usex test)
-DENABLE_V4L2=$(usex v4l)
-DENABLE_VLC=$(usex vlc)
-DENABLE_VST=ON