summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index a40d65c776fa..d4a15de786b5 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1 +1,2 @@
DIST libxfce4util-4.13.2.tar.bz2 509280 BLAKE2B 40f1fb95abff4857e976dd5f3ae8c8ad5e66e2c1c49723735e85124db71d30f204525cd74baf22e31bf405718f378b0c9ac37ec4189e1f4b9941d0eb6fc141ce SHA512 3bbb718f3a6d2213c86695b3f99d1e67c859ce635e5d066b18745d2ee57c0b2eea468b61079d8e2514c2d8f5fa847539d236ec0ed3fd17fecd9d1b36dc3595c4
+DIST libxfce4util-4.13.3.tar.bz2 511277 BLAKE2B 0815808166bc488cfa3636a18c9486fd1b3a81376766a77eef80ee24274bb290b9bece5e7786f7e412154f201bef251ce90d350c9e69db79bb893fd9081d2dac SHA512 e06bf58d46c5c3c6964a17ca8d998bd8e78bb61577ddcd855680878a890912a167212a2b4e3b347f41f84d2983e71fd1d76716db9c4a88a1d4f45a0f5aaf5e51
diff --git a/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild b/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild
new file mode 100644
index 000000000000..c83583139dad
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ vala? ( $(vala_depend) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}