summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cuetools/cuetools-1.4.1-r1.ebuild (renamed from app-cdr/cuetools/cuetools-1.4.1.ebuild)24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-cdr/cuetools/cuetools-1.4.1.ebuild b/app-cdr/cuetools/cuetools-1.4.1-r1.ebuild
index 2f34d2525069..07b455fc8677 100644
--- a/app-cdr/cuetools/cuetools-1.4.1.ebuild
+++ b/app-cdr/cuetools/cuetools-1.4.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools eutils
+inherit autotools optfeature
DESCRIPTION="Utilities to manipulate and convert cue and toc files"
HOMEPAGE="https://github.com/svend/cuetools"
@@ -12,21 +12,21 @@ SRC_URI="https://github.com/svend/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="flac mp3 vorbis"
-
-RDEPEND="
- flac? ( media-libs/flac )
- mp3? ( media-sound/mp3info )
- vorbis? ( media-sound/vorbis-tools )
-"
src_prepare() {
+ default
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README.md TODO
+ default
+
docinto extras
dodoc extras/{cueconvert.cgi,*.txt}
}
+
+pkg_postinst() {
+ optfeature "FLAC support" 'media-libs/flac'
+ optfeature "MP3 support" 'media-sound/mp3info'
+ optfeature "Vorbis support" 'media-sound/vorbis-tools'
+}