summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/lvtk/files/lvtk-1.2.0-boost-system-underlinking.patch13
-rw-r--r--media-libs/lvtk/lvtk-1.2.0.ebuild14
2 files changed, 22 insertions, 5 deletions
diff --git a/media-libs/lvtk/files/lvtk-1.2.0-boost-system-underlinking.patch b/media-libs/lvtk/files/lvtk-1.2.0-boost-system-underlinking.patch
new file mode 100644
index 000000000000..8a32358852c3
--- /dev/null
+++ b/media-libs/lvtk/files/lvtk-1.2.0-boost-system-underlinking.patch
@@ -0,0 +1,13 @@
+Prevent underlinking issues due to recent boost versions requiring boost::system
+See also: https://bugs.gentoo.org/show_bug.cgi?id=579398
+
+--- lvtk-1.2.0/wscript
++++ lvtk-1.2.0/wscript
+@@ -71,6 +71,7 @@
+ atleast_version="2.20.0", mandatory=False)
+
+ # Setup the Environment
++ conf.env.LIB_BOOST = ['boost_system']
+ conf.env.EXAMPLES_DISABLED = conf.options.disable_examples
+ conf.env.TOOLS_DISABLED = conf.options.disable_tools
+ conf.env.UI_DISABLED = conf.options.disable_ui
diff --git a/media-libs/lvtk/lvtk-1.2.0.ebuild b/media-libs/lvtk/lvtk-1.2.0.ebuild
index b5a3bb13143f..a004c89ee57f 100644
--- a/media-libs/lvtk/lvtk-1.2.0.ebuild
+++ b/media-libs/lvtk/lvtk-1.2.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
+
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"
+
inherit python-single-r1 waf-utils
DESCRIPTION="A set of C++ wrappers around the LV2 C API"
@@ -25,7 +27,9 @@ DEPEND="${RDEPEND}
media-gfx/graphviz )
virtual/pkgconfig"
-DOCS=( AUTHORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}/${P}-boost-system-underlinking.patch"
+)
src_configure() {
local mywafconfargs=(
@@ -45,7 +49,7 @@ src_install() {
# It does not respect docdir properly, reported upstream
if use doc; then
- mv "${ED}/usr/share/doc/${PF}/lvtk-1.0/html" "${ED}/usr/share/doc/${PF}/html"
- rmdir "${ED}/usr/share/doc/${PF}/lvtk-1.0"
+ mv "${ED}/usr/share/doc/${PF}/lvtk-1.0/html" "${ED}/usr/share/doc/${PF}/html" || die
+ rmdir "${ED}/usr/share/doc/${PF}/lvtk-1.0" || die
fi
}