summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/tomahawk/Manifest1
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch240
-rw-r--r--media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch126
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild78
4 files changed, 0 insertions, 445 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index 5b46c7f1068a..f1955d31d4f8 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1,2 +1 @@
-DIST tomahawk-0.9.0_pre20170808.tar.gz 9913232 BLAKE2B 5a7ebd9419fece090c0aec1f8f47bf35e1f0fbae5cd6a41803ac265e7310dadac61ba4f2e25b0d2fbbb0068cbb3f7098c1d330ac81e671be1028ed3b78d32560 SHA512 edaa4c1637ca460f838dfdd7ecc9d5dae0b66a8280deb8dc6140c673ecc76aa1055efbbac1e9b2937ec01d6dd657935b907cadceb2059f8e055305e872866c2b
DIST tomahawk-0.9.0_pre20180501.tar.gz 9913223 BLAKE2B 430fedf1a06307721d36ce733dc6f380e56ca4ba018816b4d6cf70370a383945033220bded8fef1aaeb0deb49ec89422c4ade6add997d9034620d42c43ba2b8f SHA512 51ee268a7165ee4968cd3fbd883c8e86fdee049dbf85d11ff3212d1648f08557c868c0c3f0f448c3a7fa6a825af4ee94b498b5027a788b545587bf4bae1be1c7
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch
deleted file mode 100644
index 6fb139c6bf16..000000000000
--- a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch
+++ /dev/null
@@ -1,240 +0,0 @@
-From 208a259b08676f2e0db35451b78e8225cb87547d Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 17 Apr 2018 13:09:25 +0200
-Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
-
----
- CMakeLists.txt | 3 ---
- TomahawkAddLibrary.cmake | 4 +++-
- TomahawkUse.cmake.in | 3 ---
- src/crashreporter/CMakeLists.txt | 6 ++++--
- src/libtomahawk/CMakeLists.txt | 18 +++++++++++-------
- src/tests/tomahawk_add_test.cmake | 8 ++++++--
- src/tomahawk/CMakeLists.txt | 17 ++++++++++-------
- src/tools/database-reader/CMakeLists.txt | 4 +++-
- .../tomahawk-test-musicscan/CMakeLists.txt | 4 +++-
- .../kdsingleapplicationguard/CMakeLists.txt | 4 +++-
- .../src/certificate/CMakeLists.txt | 6 +++---
- .../qxt/qxtweb-standalone/CMakeLists.txt | 10 +++++-----
- 12 files changed, 51 insertions(+), 36 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7004e1b70..616db971f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -243,9 +243,6 @@ if( NOT Qt5Core_DIR )
- macro_optional_find_package(Qt4 4.7.0 COMPONENTS ${NEEDED_QT4_COMPONENTS} )
- macro_log_feature(QT4_FOUND "Qt" "A cross-platform application and UI framework" "http://qt-project.org" TRUE "" "If you see this, although libqt4-devel is installed, check whether the \n qtwebkit-devel package and whatever contains QtUiTools is installed too")
-
-- macro(qt5_use_modules)
-- endmacro()
--
- macro(qt_wrap_ui)
- qt4_wrap_ui(${ARGN})
- endmacro()
-diff --git a/TomahawkAddLibrary.cmake b/TomahawkAddLibrary.cmake
-index 384394e45..f67a48900 100644
---- a/TomahawkAddLibrary.cmake
-+++ b/TomahawkAddLibrary.cmake
-@@ -46,7 +46,9 @@ function(tomahawk_add_library)
- endif()
-
- # HACK: add qt modules - every lib should define its own set of modules
-- qt5_use_modules(${target} Core Network Widgets Sql Xml ${LIBRARY_QT5_MODULES})
-+ if(Qt5Core_DIR)
-+ target_link_libraries(${target} Qt5::Core Qt5::Network Qt5::Widgets Qt5::Sql Qt5::Xml)
-+ endif()
-
- # definitions - can this be moved into set_target_properties below?
- add_definitions(${QT_DEFINITIONS})
-diff --git a/TomahawkUse.cmake.in b/TomahawkUse.cmake.in
-index cb39fe219..9401e1851 100644
---- a/TomahawkUse.cmake.in
-+++ b/TomahawkUse.cmake.in
-@@ -81,9 +81,6 @@ else(TOMAHAWK_QT5)
- find_package(Qt4 4.7.0 COMPONENTS ${NEEDED_QT4_COMPONENTS})
- include( ${QT_USE_FILE} )
-
-- macro(qt5_use_modules)
-- endmacro()
--
- macro(qt_wrap_ui)
- qt4_wrap_ui(${ARGN})
- endmacro()
-diff --git a/src/crashreporter/CMakeLists.txt b/src/crashreporter/CMakeLists.txt
-index b837eb941..d47c91b62 100644
---- a/src/crashreporter/CMakeLists.txt
-+++ b/src/crashreporter/CMakeLists.txt
-@@ -43,7 +43,9 @@ target_link_libraries( ${TOMAHAWK_CRASH_REPORTER_TARGET}
- ${QT_LIBRARIES}
- )
-
-+if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_CRASH_REPORTER_TARGET} Qt5::Widgets Qt5::Network)
-+endif()
-+
- set_target_properties(${TOMAHAWK_CRASH_REPORTER_TARGET} PROPERTIES AUTOMOC ON)
- install(TARGETS ${TOMAHAWK_CRASH_REPORTER_TARGET} RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR})
--
--qt5_use_modules(${TOMAHAWK_CRASH_REPORTER_TARGET} Widgets Network)
-diff --git a/src/libtomahawk/CMakeLists.txt b/src/libtomahawk/CMakeLists.txt
-index adb3edfa0..a85a835ad 100644
---- a/src/libtomahawk/CMakeLists.txt
-+++ b/src/libtomahawk/CMakeLists.txt
-@@ -500,12 +500,17 @@ set_target_properties(
- OUTPUT_NAME ${TOMAHAWK_BASE_TARGET_NAME}
- )
-
--
--qt5_use_modules(${TOMAHAWK_LIBRARY} Widgets Network Sql WebKitWidgets Concurrent Xml UiTools Svg)
--IF(APPLE)
-- qt5_use_modules(${TOMAHAWK_LIBRARY} MacExtras)
--ENDIF()
--
-+if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_LIBRARY}
-+ Qt5::Widgets Qt5::Network Qt5::Sql Qt5::WebKitWidgets Qt5::Concurrent Qt5::Xml Qt5::UiTools Qt5::Svg
-+ )
-+ if(APPLE)
-+ target_link_libraries(${TOMAHAWK_LIBRARY} Qt5::MacExtras)
-+ endif()
-+ if( UNIX AND NOT APPLE )
-+ target_link_libraries(${TOMAHAWK_LIBRARY} Qt5::DBus)
-+ endif()
-+endif()
-
- IF(QCA2_FOUND)
- INCLUDE_DIRECTORIES( ${QCA2_INCLUDE_DIR} )
-@@ -514,7 +519,6 @@ ENDIF(QCA2_FOUND)
-
- IF( UNIX AND NOT APPLE )
- LIST(APPEND LINK_LIBRARIES ${QT_QTDBUS_LIBRARIES} )
-- qt5_use_modules(${TOMAHAWK_LIBRARY} DBus)
- ENDIF( UNIX AND NOT APPLE )
-
- TARGET_LINK_LIBRARIES( ${TOMAHAWK_LIBRARY}
-diff --git a/src/tests/tomahawk_add_test.cmake b/src/tests/tomahawk_add_test.cmake
-index 464b8c918..e3e20ed4b 100644
---- a/src/tests/tomahawk_add_test.cmake
-+++ b/src/tests/tomahawk_add_test.cmake
-@@ -16,8 +16,12 @@ macro(tomahawk_add_test test_class)
- ${QT_QTCORE_LIBRARY}
- )
-
-- add_test(NAME ${TOMAHAWK_TEST_TARGET} COMMAND ${TOMAHAWK_TEST_TARGET})
-+ if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_TEST_TARGET}
-+ Qt5::Core Qt5::Network Qt5::Widgets Qt5::Sql Qt5::Xml Qt5::Test
-+ )
-+ endif()
-
-- qt5_use_modules(${TOMAHAWK_TEST_TARGET} Core Network Widgets Sql Xml Test)
-+ add_test(NAME ${TOMAHAWK_TEST_TARGET} COMMAND ${TOMAHAWK_TEST_TARGET})
-
- endmacro()
-diff --git a/src/tomahawk/CMakeLists.txt b/src/tomahawk/CMakeLists.txt
-index cb60b8012..7facdc3da 100644
---- a/src/tomahawk/CMakeLists.txt
-+++ b/src/tomahawk/CMakeLists.txt
-@@ -171,13 +171,16 @@ SET_TARGET_PROPERTIES( ${TOMAHAWK_APPLICATION_TARGET}
- RUNTIME_OUTPUT_NAME ${TOMAHAWK_RUNTIME_OUTPUT_NAME}
- )
-
--
--qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} Core Widgets Network Sql WebKitWidgets)
--if(APPLE)
-- qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} MacExtras)
--endif()
--if(WIN32)
-- qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} WinExtras)
-+if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET}
-+ Qt5::Core Qt5::Widgets Qt5::Network Qt5::Sql Qt5::WebKitWidgets
-+ )
-+ if(APPLE)
-+ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET} Qt5::MacExtras)
-+ endif()
-+ if(WIN32)
-+ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET} Qt5::WinExtras)
-+ endif()
- endif()
-
- MESSAGE( STATUS "OS_SPECIFIC_LINK_LIBRARIES: ${OS_SPECIFIC_LINK_LIBRARIES}" )
-diff --git a/src/tools/database-reader/CMakeLists.txt b/src/tools/database-reader/CMakeLists.txt
-index 72bb1e0db..d7a45f0a6 100644
---- a/src/tools/database-reader/CMakeLists.txt
-+++ b/src/tools/database-reader/CMakeLists.txt
-@@ -15,7 +15,9 @@ set_target_properties( ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET}
- target_link_libraries( ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET}
- ${TOMAHAWK_LIBRARIES}
- )
-+if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} Qt5::Core)
-+endif()
-
--qt5_use_modules(${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} Core)
- install( TARGETS ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} BUNDLE DESTINATION . RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
-
-diff --git a/src/tools/tomahawk-test-musicscan/CMakeLists.txt b/src/tools/tomahawk-test-musicscan/CMakeLists.txt
-index 097e3fc08..15c0c479f 100644
---- a/src/tools/tomahawk-test-musicscan/CMakeLists.txt
-+++ b/src/tools/tomahawk-test-musicscan/CMakeLists.txt
-@@ -14,6 +14,8 @@ set_target_properties( ${TOMAHAWK_TOOL_MUSICSCAN_TARGET}
- target_link_libraries( ${TOMAHAWK_TOOL_MUSICSCAN_TARGET}
- ${TOMAHAWK_LIBRARIES}
- )
-+if(Qt5Core_DIR)
-+ target_link_libraries(${TOMAHAWK_TOOL_MUSICSCAN_TARGET} Qt5::Core Qt5::Gui Qt5::Network Qt5::Widgets)
-+endif()
-
--qt5_use_modules(${TOMAHAWK_TOOL_MUSICSCAN_TARGET} Core Gui Network Widgets)
- install( TARGETS ${TOMAHAWK_TOOL_MUSICSCAN_TARGET} BUNDLE DESTINATION . RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
-diff --git a/thirdparty/kdsingleapplicationguard/CMakeLists.txt b/thirdparty/kdsingleapplicationguard/CMakeLists.txt
-index af4cf8704..9d6b49014 100644
---- a/thirdparty/kdsingleapplicationguard/CMakeLists.txt
-+++ b/thirdparty/kdsingleapplicationguard/CMakeLists.txt
-@@ -24,4 +24,6 @@ set_target_properties(
- PROPERTIES
- AUTOMOC TRUE
- )
--qt5_use_modules(kdsingleapplicationguard Core)
-+if(Qt5Core_DIR)
-+ target_link_libraries(kdsingleapplicationguard Qt5::Core)
-+endif()
-diff --git a/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt b/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
-index a51157cf7..bfb0b0afe 100644
---- a/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
-+++ b/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
-@@ -25,6 +25,6 @@ set_target_properties(
- PROPERTIES
- AUTOMOC TRUE
- )
--qt5_use_modules(qtcertificateaddon Core Network)
--
--
-+if(Qt5Core_DIR)
-+ target_link_libraries(qtcertificateaddon Qt5::Core Qt5::Network)
-+endif()
-diff --git a/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt b/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
-index 654a6aab5..1babe0cfc 100644
---- a/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
-+++ b/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
-@@ -74,10 +74,10 @@ ADD_LIBRARY( qxtweb-standalone STATIC
- )
-
-
--target_link_libraries( qxtweb-standalone
-- ${QT_LIBRARIES}
--)
--
--qt5_use_modules( qxtweb-standalone Network )
-+if(Qt5Core_DIR)
-+ target_link_libraries( qxtweb-standalone Qt5::Network)
-+else()
-+ target_link_libraries( qxtweb-standalone ${QT_LIBRARIES} )
-+endif()
-
- set_target_properties( qxtweb-standalone PROPERTIES AUTOMOC TRUE )
---
-2.17.0
-
diff --git a/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch b/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch
deleted file mode 100644
index 763397c613b7..000000000000
--- a/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-diff --git a/CMakeModules/FindLibLastFm.cmake b/CMakeModules/FindLibLastFm.cmake
-index a348835..545e39f 100644
---- a/CMakeModules/FindLibLastFm.cmake
-+++ b/CMakeModules/FindLibLastFm.cmake
-@@ -14,7 +14,7 @@ endif()
- # Include dir
- find_path(LIBLASTFM_INCLUDE_DIR
- # Track.h doesn't exist in liblastfm-0.3.1, was called Track back then
-- NAMES lastfm${LASTFM_LIB_SUFFIX}/Track.h
-+ NAMES lastfm/Track.h
- PATHS ${KDE4_INCLUDE_DIR}
- )
-
-diff --git a/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp b/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
-index 85b747b..098e460 100644
---- a/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
-+++ b/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
-@@ -29,17 +29,10 @@
- #include "utils/Closure.h"
- #include "utils/NetworkAccessManager.h"
-
--#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
--#include <lastfm5/ws.h>
--#include <lastfm5/User.h>
--#include <lastfm5/XmlQuery.h>
--#include <lastfm5/Track.h>
--#else
- #include <lastfm/ws.h>
- #include <lastfm/User.h>
- #include <lastfm/XmlQuery.h>
- #include <lastfm/Track.h>
--#endif
-
- using namespace Tomahawk::Accounts;
-
-diff --git a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
-index 277a62e..cea29a1 100644
---- a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
-+++ b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
-@@ -34,13 +34,8 @@
- #include "TomahawkSettings.h"
- #include "utils/NetworkAccessManager.h"
-
--#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
--#include <lastfm5/ws.h>
--#include <lastfm5/XmlQuery.h>
--#else
- #include <lastfm/ws.h>
- #include <lastfm/XmlQuery.h>
--#endif
-
- using namespace Tomahawk::Accounts;
- using namespace Tomahawk::InfoSystem;
-diff --git a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
-index 0eb3b07..6e202b2 100644
---- a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
-+++ b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
-@@ -24,15 +24,9 @@
- #include "infosystem/InfoSystemWorker.h"
- #include "DllMacro.h"
-
--#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
--#include <lastfm5/Track.h>
--#include <lastfm5/Audioscrobbler.h>
--#include <lastfm5/ScrobblePoint.h>
--#else
- #include <lastfm/Track.h>
- #include <lastfm/Audioscrobbler.h>
- #include <lastfm/ScrobblePoint.h>
--#endif
-
- #include <QObject>
-
-diff --git a/src/libtomahawk/utils/TomahawkUtils.cpp b/src/libtomahawk/utils/TomahawkUtils.cpp
-index 0baa27c..cf808d9 100644
---- a/src/libtomahawk/utils/TomahawkUtils.cpp
-+++ b/src/libtomahawk/utils/TomahawkUtils.cpp
-@@ -32,11 +32,7 @@
- #include "Track.h"
-
- #ifdef LIBLASTFM_FOUND
-- #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
-- #include <lastfm5/ws.h>
-- #else
- #include <lastfm/ws.h>
-- #endif
- #endif
-
- #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
-diff --git a/src/tomahawk/Scrobbler.h b/src/tomahawk/Scrobbler.h
-index 01c2695..fab0ca6 100644
---- a/src/tomahawk/Scrobbler.h
-+++ b/src/tomahawk/Scrobbler.h
-@@ -20,15 +20,10 @@
- #ifndef TOMAHAWK_SCROBBLER_H
- #define TOMAHAWK_SCROBBLER_H
-
-+#include "lastfm/ScrobblePoint.h"
- #include "Result.h"
- #include "infosystem/InfoSystem.h"
-
--
--#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
--#include <lastfm5/ScrobblePoint.h>
--#else
--#include <lastfm/ScrobblePoint.h>
--#endif
- #include <QObject>
-
- /**
-diff --git a/src/tomahawk/TomahawkApp.h b/src/tomahawk/TomahawkApp.h
-index 953140b..c161d07 100644
---- a/src/tomahawk/TomahawkApp.h
-+++ b/src/tomahawk/TomahawkApp.h
-@@ -64,11 +64,7 @@ namespace Tomahawk
- }
-
- #ifdef LIBLASTFM_FOUND
-- #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
-- #include <lastfm5/NetworkAccessManager.h>
-- #else
- #include <lastfm/NetworkAccessManager.h>
-- #endif
- #include "Scrobbler.h"
- #endif
-
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
deleted file mode 100644
index 8cb2950b9aa9..000000000000
--- a/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-COMMIT=00f602e10203b76fc28b4615868c567e6bd4ced4
-inherit kde5 vcs-snapshot
-
-DESCRIPTION="Multi-source social music player"
-HOMEPAGE="https://www.tomahawk-player.org/"
-SRC_URI="https://github.com/${PN}-player/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+hatchet telepathy xmpp"
-
-CDEPEND="
- $(add_frameworks_dep attica)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtsql)
- $(add_qt_dep qtsvg)
- $(add_qt_dep qtwebkit)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- $(add_qt_dep qtxml)
- app-crypt/qca:2[qt5(+)]
- dev-cpp/lucene++
- dev-cpp/sparsehash
- dev-libs/boost:=
- dev-libs/qtkeychain:=[qt5(+)]
- >=dev-libs/quazip-0.7.2[qt5(+)]
- >=media-libs/liblastfm-1.0.9-r1[qt5(+)]
- >=media-libs/taglib-1.8.0
- media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
- >=net-libs/gnutls-3.2:=
- x11-libs/libX11
- hatchet? ( dev-cpp/websocketpp )
- telepathy? ( >=net-libs/telepathy-qt-0.9.7-r1[qt5(+)] )
- xmpp? ( >=net-libs/jreen-1.3.0[qt5(+)] )
-"
-DEPEND="${CDEPEND}
- $(add_qt_dep designer)
- $(add_qt_dep linguist-tools)
- $(add_qt_dep qtconcurrent)
-"
-RDEPEND="${CDEPEND}
- app-crypt/qca:2[ssl]
-"
-
-PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )
-
-src_prepare() {
- kde5_src_prepare
- has_version "media-libs/liblastfm[qt5]" &&
- eapply "${FILESDIR}/${PN}-liblastfm-cmake.patch"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CRASHREPORTER=OFF
- -DBUILD_TESTS=OFF
- -DBUILD_TOOLS=OFF
- -DBUILD_WITH_QT4=OFF
- -DWITH_KDE4=OFF
- -DBUILD_HATCHET=$(usex hatchet)
- -DWITH_TelepathyQt=$(usex telepathy)
- -DWITH_Jreen=$(usex xmpp)
- )
-
- if [[ ${KDE_BUILD_TYPE} != live ]]; then
- mycmakeargs+=( -DBUILD_RELEASE=ON )
- fi
-
- kde5_src_configure
-}