summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/dwb/Manifest1
-rw-r--r--www-client/dwb/dwb-2013.03.30.ebuild58
-rw-r--r--www-client/dwb/dwb-2014.03.07.ebuild52
3 files changed, 0 insertions, 111 deletions
diff --git a/www-client/dwb/Manifest b/www-client/dwb/Manifest
index fd8929d10e4a..517ea6659c6f 100644
--- a/www-client/dwb/Manifest
+++ b/www-client/dwb/Manifest
@@ -1,2 +1 @@
-DIST dwb-2013.03.30.tar.gz 410020 SHA256 bb12964be76d991f7b71d6c917eeecc3b356784b4a74194ffbf5f643d6cf2312 SHA512 2e9fa8cb18cadd8a27783851a825011ba5662a9e1b8ae3109e354b30f2f9e439fafd6034888a2d4d8195c8ff10b9ea70651981ea00938efb48d01256130cf9a6 WHIRLPOOL 3bb598b132a70029f1bbed4b794ba97efce1849e7fd77ea11531f14f1dc978f81aee34f1afcdedaca50153eb980278080cac48219c0bc8d5e4fd8779a5dddc0b
DIST dwb-2014.03.07.tar.gz 474179 SHA256 bfbe3e366b27c969876f9ee7954f138b1d49a270aa84a14ce43e01591ab69b62 SHA512 7d3eb353ab7f7aa50bd678c75d72d1bbab0e5831991a1f4a1b2c4a8e134ccc90ab699932f5fd64efba157049c4863f258e329738529b7e03e2a56da737ca03a1 WHIRLPOOL 1864778d89d7fade7bf1fbeea4c5adf99cb11d63a56d255706fb3d15f19c9b0ce77ec124ad406b01b7fde8d39764ebda1f4fa70ee106731dea8f796b4e38a3ce
diff --git a/www-client/dwb/dwb-2013.03.30.ebuild b/www-client/dwb/dwb-2013.03.30.ebuild
deleted file mode 100644
index 6b6ab7bf12c5..000000000000
--- a/www-client/dwb/dwb-2013.03.30.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
-HOMEPAGE="https://portix.bitbucket.org/dwb/"
-SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="examples gtk3"
-
-RDEPEND=">=net-libs/libsoup-2.32:2.4
- dev-libs/json-c
- net-libs/gnutls
- !gtk3? (
- >=net-libs/webkit-gtk-1.8.0:2
- x11-libs/gtk+:2
- )
- gtk3? (
- >=net-libs/webkit-gtk-1.8.0:3
- x11-libs/gtk+:3
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-verbose-build.patch
- epatch "${FILESDIR}"/${P}-json-c.patch
-
- sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
-}
-
-src_compile() {
- local myconf
- use gtk3 && myconf+=" GTK=3"
-
- # uclibc and other systems don't have execinfo.h (bug #465170)
- if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
- myconf+=" WITHOUT_EXECINFO=1"
- fi
-
- emake CC="$(tc-getCC)" ${myconf}
-}
-
-src_install() {
- default
-
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/www-client/dwb/dwb-2014.03.07.ebuild b/www-client/dwb/dwb-2014.03.07.ebuild
deleted file mode 100644
index ce603735031f..000000000000
--- a/www-client/dwb/dwb-2014.03.07.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
-HOMEPAGE="https://portix.bitbucket.org/dwb/"
-SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="examples gtk3"
-
-RDEPEND=">=net-libs/libsoup-2.32:2.4
- dev-libs/json-c
- net-libs/gnutls
- !gtk3? (
- >=net-libs/webkit-gtk-1.8.0:2
- x11-libs/gtk+:2
- )
- gtk3? (
- >=net-libs/webkit-gtk-1.8.0:3
- x11-libs/gtk+:3
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-verbose-build.patch
-
- sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
-}
-
-src_compile() {
- local myconf
- use gtk3 && myconf+=" GTK=3"
-
- emake CC="$(tc-getCC)" ${myconf}
-}
-
-src_install() {
- default
-
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}