summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/httpauth/Manifest1
-rw-r--r--dev-python/httpauth/httpauth-0.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/httpauth/Manifest b/dev-python/httpauth/Manifest
index 8dff66939152..1840fe76521a 100644
--- a/dev-python/httpauth/Manifest
+++ b/dev-python/httpauth/Manifest
@@ -1 +1,2 @@
DIST httpauth-0.3.tar.gz 4440 BLAKE2B 41c9ba9ee50b7fcc4ed409f4b34897b5243df4065fd081cd5c0951ebe2719a34a424e59c21adbcd9be133c8fe4fa4ad9dc7bec561285b873987f982f684b3682 SHA512 aa35148322a1c5ffc22a132d3062d300118aa23181a0008018d0aacfd473758d86d50ff1236d88126858a53e2f45aeea938988b2d1a8f62f80a97d8c2cc69822
+DIST httpauth-0.4.gh.tar.gz 5437 BLAKE2B 9db9085afab06a8189e6ecad38a7da8a5599a39f6ca257f3a29818eeea100ca8301c704873977177ca6f40f46953365d5af14a713f87ea85747d84d006787850 SHA512 3e42bd400447f0179ae70662d79c61378a20dd1fcec2684d6b374de3114e362d1ad177ac7dcd9624a167de213df67438933161c083515a1ec6d20aadc6003dc4
diff --git a/dev-python/httpauth/httpauth-0.4.ebuild b/dev-python/httpauth/httpauth-0.4.ebuild
new file mode 100644
index 000000000000..32e48b05348c
--- /dev/null
+++ b/dev-python/httpauth/httpauth-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
+HOMEPAGE="
+ https://github.com/jonashaag/httpauth/
+ https://pypi.org/project/httpauth/
+"
+# 0.4 has broken sdist
+# https://github.com/jonashaag/httpauth/issues/6
+SRC_URI="
+ https://github.com/jonashaag/httpauth/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest