summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-calculators/pcalc/Manifest1
-rw-r--r--sci-calculators/pcalc/pcalc-5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/Manifest b/sci-calculators/pcalc/Manifest
index 08cc54e05eb6..3d856c63a39f 100644
--- a/sci-calculators/pcalc/Manifest
+++ b/sci-calculators/pcalc/Manifest
@@ -1 +1,2 @@
DIST pcalc-4.tar.xz 68948 BLAKE2B f7d17e3ebf76aeccd9b7c74fe6ecfa7de94d8450d302e3b094b57f4050e0be2448887ea131496ab00ee140d0a44b0dd8d5b5564feb8fdc47d2fbbe5010af73d9 SHA512 6492ca89c5f60549f9388d8b7edad21c1c912feea0ee1a1271d730a63832c3b562b1a6bc9f69a0bd3118407906646c8d8fbed6c6d9a62db6a6bbde22579c1fd0
+DIST pcalc-5.tar.xz 72148 BLAKE2B 8095e9f17ebb8a6271460e8aa8d35d8ae588f4e046e3ff60c0a8ee4fbcb05a8afa96095baf2656be47a45dda5966e89a71e25c651839837d366d307e9ac532ac SHA512 13a33ae5c3fb40632c89f7c0dc7b5a2fa497f090393022ab57ab15f866b1bf122558085cdd2b7ab42aae9018b7031fe0e85df4c9d31fc359b87ffd930e2f16e7
diff --git a/sci-calculators/pcalc/pcalc-5.ebuild b/sci-calculators/pcalc/pcalc-5.ebuild
new file mode 100644
index 000000000000..398bb59b6c34
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}