summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/tf2_ros/Manifest1
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/Manifest b/dev-ros/tf2_ros/Manifest
index 8403f0e7e3b7..d8e2f36134a3 100644
--- a/dev-ros/tf2_ros/Manifest
+++ b/dev-ros/tf2_ros/Manifest
@@ -1,3 +1,4 @@
DIST geometry2-0.5.14.tar.gz 147162 SHA256 0fd24baaa61aa4cf5d97545da86b42b51814cfc957dc793051043dbe9697753d SHA512 1e32dbfbd46a2d72dcc53cf67914bdc6bd1907cf8d9b6c24c5b73e9738a7068b1b974ea434a267f907f276bf70b85f7169d85679449402e0808edadb9fe21e82 WHIRLPOOL 12711071b049e7e5f9f334206896f25d9479386f7b4a6d74d9c341ce80f4e767c7466d57be966048fe28bf2e7fe1423d38bd6de70ec615575f7f4bcb718afc1d
DIST geometry2-0.5.15.tar.gz 147275 SHA256 fba4c223e85923060d76f1113b346207b2d36cda0e2c3393ec96ff99ba918dbe SHA512 10a750948157904c0812aaae85e21eaf5c85dfef3770d418fd0c592a9179cef9fc2082ecc125be0fd0032e705dfb678d45930d3aa2cd0986a71c2e0a7307722c WHIRLPOOL d982cae97a0d3de2320a9a4318f84aef1403d7f59c1dfe88fd274a517d4e5b5263434cffe16cf2a346ddccecb4e3263445c3008feb9ec1efb053361dc51286e1
+DIST geometry2-0.5.16.tar.gz 154351 SHA256 61001913ea7568a513171f57a09f02905918cee0b558baa27f7439fbb79700cb SHA512 11909db98af78bbdef8d1a7dc5f20d3ff3cfcb0afc0e1d53b97a1ffe99aecea911f09364593eb232d7514a4caa192141404d892a33fc7ea9f5ce924ecf99fc51 WHIRLPOOL 43fb2d7b53fa3a134c3a2881d8985a1cc5f34983aac5031647791149301063e1679f69a08ec0ac983b708b25fda5871d0477c237b91864987115fcb2063a622f
DIST geometry_experimental-0.5.13.tar.gz 134107 SHA256 20ad7d3b610c70e8c666937d6a29ef53dac9181025427ee6d0664c67ff94b43f SHA512 5b31a2ec2c8f852934c1c9a6aa0127c96b8f334f178742111c673195562a240649ac11ddde8d9738defae99184bdd83a57430fe6f17eb4cbd08ae600bfa7d43d WHIRLPOOL 06da030383725aaeda8626f36b56911cc05c025b538904f33cdc69975027f610113945a3479d85fe83df841fcb1f4902b8927cae2a2272e44f59b86c97d844fc
diff --git a/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild b/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild
new file mode 100644
index 000000000000..00234a1ad22c
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"