summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0-r1.ebuild (renamed from dev-ml/cstruct/cstruct-6.2.0.ebuild)13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-ml/cstruct/cstruct-6.2.0.ebuild b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
index 6d78859ac5fc..b397c637c091 100644
--- a/dev-ml/cstruct/cstruct-6.2.0.ebuild
+++ b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
@@ -12,7 +12,18 @@ SRC_URI="https://github.com/mirage/ocaml-cstruct/releases/download/v${PV}/${P}.t
LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/cppo
+ dev-ml/ocaml-migrate-parsetree
+ dev-ml/ppx_sexp_conv
+ dev-ml/ppxlib
+ dev-ml/sexplib
+ )
+"
src_compile() {
dune-compile ${PN}