summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ppx_sexp_value/Manifest1
-rw-r--r--dev-ml/ppx_sexp_value/ppx_sexp_value-0.15.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_value/Manifest b/dev-ml/ppx_sexp_value/Manifest
index fcec929450bf..04a564ff5c07 100644
--- a/dev-ml/ppx_sexp_value/Manifest
+++ b/dev-ml/ppx_sexp_value/Manifest
@@ -1 +1,2 @@
DIST ppx_sexp_value-0.14.0.tar.gz 7740 BLAKE2B f495d0b9032a73cd6a62292185e77cfe6206bb06564e663c04a20c9430dd4188da529bef6428a7a07309109ec7fc51d3909ac58d5760c1fab618f59eee8a6b63 SHA512 d33ed503025e07588a21ca6796004dd53ddfb9f67f3527d066c4767734fb8723d0a9d31082d285ba82996d8b69faecb624f116046ea8048637f05773ee3e89a8
+DIST ppx_sexp_value-0.15.0.tar.gz 7839 BLAKE2B 72ac20f7bae60979f2b90c2103773549af655fff9c291d8f0afbfb773495ea2e387ce8149e782fd87db484ea882b9a35347a80472f37d9d1ab6f26bbff845db3 SHA512 b6eb67114c8d63b7eeeb63c5ce1c043a4c8879bd6502733449b3b1d665d345c9685ffefc0f8b0a3203b31e169f238f7decc882e72b0436601d1461e86b0f5d03
diff --git a/dev-ml/ppx_sexp_value/ppx_sexp_value-0.15.0.ebuild b/dev-ml/ppx_sexp_value/ppx_sexp_value-0.15.0.ebuild
new file mode 100644
index 000000000000..20344bbab120
--- /dev/null
+++ b/dev-ml/ppx_sexp_value/ppx_sexp_value-0.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_value"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_here:${SLOT}
+ dev-ml/ppx_sexp_conv:${SLOT}
+"
+RDEPEND="${DEPEND}"