summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r3.ebuild b/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r3.ebuild
new file mode 100644
index 000000000000..4bf7c58607fc
--- /dev/null
+++ b/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the Rc4 algorithm"
+HOMEPAGE="https://github.com/caiges/Ruby-RC4"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/"README"/"README.md"/' Rakefile || die
+}