summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-3.32.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index 11b137d7e55b..7cbd792203de 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1 +1,2 @@
DIST yelp-3.30.0.tar.xz 1393176 BLAKE2B a00277f7a2498d2a6c51c8375fc52293a40f111ab441bf00e25fbfa054914e4752a65b8fcb5eace74393c61431a0e5c9bcebe8b35dc8b00f96d3a3c362079f77 SHA512 fd6da1731e55bd796593f0ed4d566b380996d21ca0264033a5b6afaf0ba8d445a2b04a9fcbe0a1091f2244a6ee2c92814bbb86db8de59b2c230b746dbd0df564
+DIST yelp-3.32.2.tar.xz 1538964 BLAKE2B f4d7947f29b40bc033e2d3e010c39f8ff43de765bc4a2c446f02beab4888ded287681db2c140951f19aa9075aceff6f08658d0f434b5cd9d39e7e53e6cc00c31 SHA512 be0e2a7919ba8aef8eeb13e4d195e745afcd113350b32bad5ccf204f544107bebcadee364508402ad7906dd5484b9f21288ae13edcaab47a02b54e31f3379cfd
diff --git a/gnome-extra/yelp/yelp-3.32.2.ebuild b/gnome-extra/yelp/yelp-3.32.2.ebuild
new file mode 100644
index 000000000000..0f9ebb4f2a18
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.32.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.27.1
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ eapply "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=""
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}