summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-20.3.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 66027511a56d..32ecf087955e 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1 @@
-DIST packaging-20.3.tar.gz 73015 BLAKE2B 863a04124543d510455ffd6cd6974e7b3ed0c43e02baa5124631e24e7d56017d0289475fbcd9a4f038607c4a13aced32d2b98a82d975903afa154b520feb0019 SHA512 b27ad6f72bfe0965a6e6bff78e4e37d4cbab73dc0a1b019673c85615c9d99edf237effeb9756702c6e8c1575a2d981f6d1af364c73d0a451fbb167d64678630f
DIST packaging-20.4.tar.gz 74402 BLAKE2B 3c667c1605445aec37d264ec3846a1a6678f13a12aecc09a6d16e09ea27041fcd65d23538acef4f6272ab0458ce479c42906b15cb6eddd9c8001b1970c23e4fc SHA512 d53912041a9950efb5d221fc968adc328c2ef1e54ec9806d2158fd6db1b170e37afb05213f5750b10c59927504083ca3781c958caa0c802b1c7c0fe1ac1682a4
diff --git a/dev-python/packaging/packaging-20.3.ebuild b/dev-python/packaging/packaging-20.3.ebuild
deleted file mode 100644
index 046ab3f6ba5d..000000000000
--- a/dev-python/packaging/packaging-20.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- rm -rv "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}