summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/lukko/Manifest2
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.3.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/lukko/Manifest b/dev-haskell/lukko/Manifest
index 4bd93cb9427f..ba17dfb30a81 100644
--- a/dev-haskell/lukko/Manifest
+++ b/dev-haskell/lukko/Manifest
@@ -1 +1,3 @@
DIST lukko-0.1.1.2.tar.gz 28366 BLAKE2B 8e7a0257c187ed76f2399a2ca381210ad44d683faff74ca583658eab13545e6809fe6ea57b4c4c22c16560272c0d53736183437e4f5ad64919d98dbac239a864 SHA512 fe3a6687b741491ebaeace29c8d4d01307fad43f0e649c087fef24ec227eb231541fa1500e1685c814eb2a1ea472546033e837ce84fa64df79f00b19f8abebb6
+DIST lukko-0.1.1.3.cabal 4556 BLAKE2B 61ae605ec201a1870aba505e4434ace0b6f153b10eb740e2a28cb44cdf948086eb58485c976c0ab895e26521175f9e97c0c4b1ef296831a671c8c0ae64f719b2 SHA512 ac85483d44211bac42bb5bba64a790a2c328db3e3afb9f2837a50a792a13b6efcaf9298705051c6f54f151786c8a41c79f4929f8d5ef3934cc918dfe8091c12b
+DIST lukko-0.1.1.3.tar.gz 28575 BLAKE2B 9f0006d05ba1db03de6fda88265e8949797201124f71ca6690113431f398eb59f19ec67363eb6b2834cac136e985b84882d45dfeb71c67e1147dd000c06cd243 SHA512 8bed8b88a101883f642bb9d9d41512436f5c80db5ea1ad0cddb069c6d09257d21b56a60e0f70b57453e91126065fbfdeeb721064763e64de1975dcb51b1a484a
diff --git a/dev-haskell/lukko/lukko-0.1.1.3.ebuild b/dev-haskell/lukko/lukko-0.1.1.3.ebuild
new file mode 100644
index 000000000000..6c5b7eb3841f
--- /dev/null
+++ b/dev-haskell/lukko/lukko-0.1.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: +ofd-locking
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File locking"
+HOMEPAGE="https://hackage.haskell.org/package/lukko"
+HACKAGE_REV="2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+ >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4
+ >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.13 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=ofd-locking
+}