summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-forensics/libewf/Manifest1
-rw-r--r--app-forensics/libewf/libewf-20140608-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-forensics/libewf/Manifest b/app-forensics/libewf/Manifest
index 0632e197e7d2..b6ddeb6103ea 100644
--- a/app-forensics/libewf/Manifest
+++ b/app-forensics/libewf/Manifest
@@ -1,2 +1,3 @@
DIST libewf-20130416.tar.gz 1968288 BLAKE2B a61cd2239bfc12b1107bf3c6f68106027a1b08ca644dd8d8ca9dda331f902d1ba2e74dc516a3ed1dbf90f2926c7f654496bf6dd103d5c3f615bab653c8616fd0 SHA512 e84e920dfe6e5a313bc165b1796ab9681c5b42fdefc7120b4f1c0f4e42b220d8192e03df2707051cf16f4cc991facdfdbd39042dcfb645ac7a27b549e02bd96e
+DIST libewf-20140608-libuna-remove-inline.patch 34909 BLAKE2B e0b4fdcdf3e791992f32bd5251d3a5e6c8d193fe33508620e040ae11c83cf0c308ffd9cce31b548be03e6ec3c0a0623eb25a1731d402296908923d2c6643bbc0 SHA512 01b82d1ebe921a3b572ba061886bddc76d57c6e13f7997ca139baf790d3be7a8e855a50a05915788a7afb85afd46f9cd638c279ba57f7c36398dadd94bc32fc7
DIST libewf-20140608.tar.gz 2129518 BLAKE2B aaa8e95f243e887494c5a50c1706864b4613e5731aa49ec2d2510b81984be9df70eeb18c1d5c56f97894536d55a16c2496eae8c662f6ab54e29c142f460fb188 SHA512 f77f01e3452027bff71e644708744e0774e1e397c70e2ebd687983730f03ffb01b26fec782bec79971e149caac5029484f3d9073c3a8042df951bfc542fe2436
diff --git a/app-forensics/libewf/libewf-20140608-r1.ebuild b/app-forensics/libewf/libewf-20140608-r1.ebuild
new file mode 100644
index 000000000000..4f45bb342f11
--- /dev/null
+++ b/app-forensics/libewf/libewf-20140608-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit eutils autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="https://github.com/libyal/libewf"
+SRC_URI="https://googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/${P}.tar.gz
+ https://dev.gentoo.org/~gokturk/distfiles/app-forensics/libewf/libewf-20140608-libuna-remove-inline.patch"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python unicode"
+IUSE="bfio debug ewf +fuse +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
+ fuse? ( sys-fs/fuse:= )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${DISTDIR}"/${P}-libuna-remove-inline.patch )
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with bfio libbfio)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}