summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dialup/picocom/Manifest1
-rw-r--r--net-dialup/picocom/picocom-3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/picocom/Manifest b/net-dialup/picocom/Manifest
index 530efc98da0a..9f784443f1fa 100644
--- a/net-dialup/picocom/Manifest
+++ b/net-dialup/picocom/Manifest
@@ -1,2 +1,3 @@
DIST picocom-2.2.tar.gz 88670 BLAKE2B 47ba36e08e0c45b81a88a4eb66044e69814581c278193c228f83f1e0161c87d450997d26252b70bc66106ee1667d24da07f8a2451c6ae03df62ca86100a26824 SHA512 21495af30b81dfd1b3f4fea1ecf93c3a9252be1ae2ba94c7a2a07ceb75f562bc2ebc6ef6a8ae61f810ff5c121d4ab572a6f8ba75283e2cb28cf9886f834df0fa
DIST picocom-3.0.tar.gz 116478 BLAKE2B 7c6b6518b1c687c60a34c8146eeaeed1bbbb9aeb5d3b09cfac524dab2c0ac8064471daeea32de3d3fabbe9afbd7dd066ea817c7c2c4942033808b02ec782afbe SHA512 3c22a7638be63cffcc3191479bd442a142e9b3d85815a000fa7ad7e04a4314f07331931d8f240f226ddb02dd15c79cd4fda98fc907629ad34820d481eb690bf0
+DIST picocom-3.1.tar.gz 121686 BLAKE2B e7f478e7d00e791fb2ea7248ff31e480d05c5c1fe35941f85689a5df19646175e3c698222e430786874c0508c44a0c1f8ecc4b69c889a40e7411c7b54c67249a SHA512 ff1888494ae0e24a151e19ac3abcdbb499e42eb1abcea401a7c6c3b532be3d64ddd81a511641d1ce0119dc5da3d2804ce8eaff262a9d578bfe8e22fdf6e55ad1
diff --git a/net-dialup/picocom/picocom-3.1.ebuild b/net-dialup/picocom/picocom-3.1.ebuild
new file mode 100644
index 000000000000..e5d52e872d4f
--- /dev/null
+++ b/net-dialup/picocom/picocom-3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="https://github.com/npat-efault/picocom"
+SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.1
+ dodoc CHANGES.old CONTRIBUTORS README.md
+}