summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-propro/Manifest1
-rw-r--r--dev-php/pecl-propro/pecl-propro-2.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-propro/Manifest b/dev-php/pecl-propro/Manifest
index 7c5dcb1d2184..6ada5159724f 100644
--- a/dev-php/pecl-propro/Manifest
+++ b/dev-php/pecl-propro/Manifest
@@ -1,2 +1,3 @@
DIST propro-1.0.2.tgz 13393 BLAKE2B c451ad6e1e0f93308497514de22a949dfbbea54e326c18688d6883aeb4d6adb920c42adfa458faf4c350755da72c1db06f77efc408fbc182fbb950e2f8b33302 SHA512 a4a3216d13c412051c063e0370c5f0badb65aa7054a43b0f6eb387a7a5fbbba1800b7f5f5113ba68ca8c7fe19932184a069864d1362239c71e0f55466c9cc8eb
DIST propro-2.0.1.tgz 13399 BLAKE2B 88b099602ed19da96570c6b65981158d1f8f335470e6cd7afa517844a71258b04d9cb294bf91c15a23bbc016b303b2e42a2dea263808e0ed92905ba9ba47247f SHA512 c5a5f7c1fdf042d49597df789dc2b2e4e1512e7320a3a39cad344a9dfa3b9253b4a98d2f33e10e04ee608e5b8d1e1b50238787510db0a0f99d8f8b45b91c5c22
+DIST propro-2.1.0.tgz 14253 BLAKE2B 44c9bde831486fa41520ce75b313865b90a057acd0d566ae7e5c2aca97240e089580ca79ef04842a57a5d8eb76a179e57c505e977913567c1e97260f87fe2165 SHA512 94fc97f7bf17661ec7ecbe4d13b4fc98b8381469140d121fef49d32a4b767e956ed87b9f5bbb794f27ca47ce4b7b3125ea2b9091eb9d1f0a52b5c8f9df7ee145
diff --git a/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
new file mode 100644
index 000000000000..1c8c99bad920
--- /dev/null
+++ b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="propro"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable property proxy API for PHP"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}