summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/lazarus/Manifest1
-rw-r--r--dev-lang/lazarus/lazarus-1.0.12.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-lang/lazarus/Manifest b/dev-lang/lazarus/Manifest
index f6b7e298e2cc..ba749c4d1a89 100644
--- a/dev-lang/lazarus/Manifest
+++ b/dev-lang/lazarus/Manifest
@@ -1,4 +1,3 @@
-DIST lazarus-1.0.12-0.tar.gz 47687878 BLAKE2B 7a230f8ad433fefd514d8fca128e1ad127ea2a232c2061080d4146b5276ef82bd442be6a522a5eb4a9221338e8d13cf9d3cc954f712dfbc521d8fd74b07389f7 SHA512 2a106c4bff2135ace815f789057f25fea1902edc972503e883547d7cc6d50b585ae54676cba734cce616064864ce535b3a4fcd7892763d15aafdf262dbe24293
DIST lazarus-1.8.4-python.tar.gz 1060859 BLAKE2B 4d6f7dc275aacd0f70d9f7c85aba99a7722b02165a5bf287bfeed46f28e3b36c5abeac19bd7c6555250102dce169f7c9c213b634ce1b634c24dadc84171aed10 SHA512 f244b4e86410fdb2ffe8ccba7fcb51c270286172b6102f757118827cac3b652210a625d65dd6c017c1992983527792ed64334291ab0e0b824f187316452c56b5
DIST lazarus-1.8.4.tar.gz 63130653 BLAKE2B f9b2ba9971f1a9a9c3b8d2004bd3516c12db5384bb6243ef275c2fc0d458634fba0c1c23e7ecd5c160c1204d6cc2b4ebc340ce8bb5cfdd9c531f8c36ae59d1e2 SHA512 82cdc3c32dddf8e67c0bed9292a9a924227bab50f22ca479f5e98ecccbf60dd66c7f886ecb8e2979d9d8fccc3d25462ee8c55fcab085aa4194b4704660e0b95d
DIST lazarus-2.0.6.tar.gz 65558951 BLAKE2B f5289562adcfeab86af074de9fc44d7faf5939655587ea9951559bbefc15ce1730e7b7dafb6ec1d0a11eb0f8f069309b8fa0a305051c5cc9ea0fcf9665e883bc SHA512 cdb4c5861e130c12bf0a4938a73c439f2766a73008678028d7e9c9bcabe7b277e70025a7c720a5c14c157cf0227e0ff629a44cf983537b3afbf341343e816d07
diff --git a/dev-lang/lazarus/lazarus-1.0.12.ebuild b/dev-lang/lazarus/lazarus-1.0.12.ebuild
deleted file mode 100644
index 91bc2bbace9a..000000000000
--- a/dev-lang/lazarus/lazarus-1.0.12.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit desktop epatch
-
-RESTRICT="strip" #269221
-
-FPCVER="2.6.0"
-
-SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
-LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
-KEYWORDS="amd64 x86"
-DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
-HOMEPAGE="https://www.lazarus-ide.org/"
-IUSE="minimal"
-SRC_URI="https://downloads.sourceforge.net/project/${PN}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${PN}-${PV}-0.tar.gz"
-
-DEPEND=">=dev-lang/fpc-${FPCVER}[source]
- net-misc/rsync
- x11-libs/gtk+:2"
-RDEPEND="${DEPEND}
- !=gnome-base/librsvg-2.16.1"
-DEPEND="${DEPEND}
- >=sys-devel/binutils-2.19.1-r1"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch
-
- # Use default configuration (minus stripping) unless specifically requested otherwise
- if ! test ${PPC_CONFIG_PATH+set} ; then
- local FPCVER=$(fpc -iV)
- export PPC_CONFIG_PATH="${WORKDIR}"
- sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
- sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
- #sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
- fi
-}
-
-src_compile() {
- LCL_PLATFORM=gtk2 emake \
- $(usex minimal "" "bigide") \
- -j1
-}
-
-src_install() {
- diropts -m0755
- dodir /usr/share
- # Using rsync to avoid unnecessary copies and cleaning...
- # Note: *.o and *.ppu are needed
- rsync -a \
- --exclude="CVS" --exclude=".cvsignore" \
- --exclude="*.ppw" --exclude="*.ppl" \
- --exclude="*.ow" --exclude="*.a"\
- --exclude="*.rst" --exclude=".#*" \
- --exclude="*.~*" --exclude="*.bak" \
- --exclude="*.orig" --exclude="*.rej" \
- --exclude=".xvpics" --exclude="*.compiled" \
- --exclude="killme*" --exclude=".gdb_hist*" \
- --exclude="debian" --exclude="COPYING*" \
- --exclude="*.app" \
- "${S}" "${ED%/}"/usr/share \
- || die "Unable to copy files!"
-
- dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
- dosym ../share/lazarus/startlazarus /usr/bin/lazarus
- dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
- use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
- dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
-
- make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
-}