summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/ganeti-htools/Manifest1
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch14
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-base-4.patch171
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch9
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-ghc-7.10.patch29
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild50
-rw-r--r--app-emulation/ganeti-htools/metadata.xml27
7 files changed, 0 insertions, 301 deletions
diff --git a/app-emulation/ganeti-htools/Manifest b/app-emulation/ganeti-htools/Manifest
deleted file mode 100644
index e33360f6828d..000000000000
--- a/app-emulation/ganeti-htools/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ganeti-htools-0.3.1.tar.gz 300261 BLAKE2B b7eb1a94ff4a5026955a9b8c7331dc6b529ff9eb688ae4cafe1822b93d3705bff4f9c5006bd674cd03ecb2bf41d0e32142d039b485e08a797240e8f51f553c2a SHA512 76acc476dc5b3add808db41b7aad4be6ee4b62d31e81eaefa17fbf010daa817bcc920b4e290727ebeddebbe6015017b19d2b7643dbc6d529f158b9746b7a4b43
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch
deleted file mode 100644
index fd7943fe7057..000000000000
--- a/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 5e189fc..bfdf175 100644
---- a/Makefile
-+++ b/Makefile
-@@ -20,7 +20,8 @@ $(HALLPROGS): %: %.hs Ganeti/HTools/Version.hs $(HSRCS) Makefile
-
- test live-test: HEXTRA=-fhpc -Wwarn -fno-warn-missing-signatures \
- -fno-warn-monomorphism-restriction -fno-warn-orphans \
-- -fno-warn-missing-methods -fno-warn-unused-imports
-+ -fno-warn-missing-methods -fno-warn-unused-imports \
-+ -package $(shell ghc-pkg list | sed -n '/ QuickCheck-1./p')
-
- $(DOCS) : %.html : %
- rst2html -v --strict $< $@
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-base-4.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-base-4.patch
deleted file mode 100644
index aa0d973a9e40..000000000000
--- a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-base-4.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-diff --git a/Ganeti/HTools/CLI.hs b/Ganeti/HTools/CLI.hs
-index b000a00..d9177c6 100644
---- a/Ganeti/HTools/CLI.hs
-+++ b/Ganeti/HTools/CLI.hs
-@@ -74,11 +74,11 @@ module Ganeti.HTools.CLI
-
- import Data.Maybe (fromMaybe)
- import qualified Data.Version
--import Monad
-+import Control.Monad
- import System.Console.GetOpt
- import System.IO
- import System.Info
--import System
-+import System.Exit
- import Text.Printf (printf)
-
- import qualified Ganeti.HTools.Version as Version(version)
-diff --git a/Ganeti/HTools/ExtLoader.hs b/Ganeti/HTools/ExtLoader.hs
-index 0412c1b..17b8449 100644
---- a/Ganeti/HTools/ExtLoader.hs
-+++ b/Ganeti/HTools/ExtLoader.hs
-@@ -36,10 +36,11 @@ module Ganeti.HTools.ExtLoader
- ) where
-
- import Data.Maybe (isJust, fromJust)
--import Monad
-+import Control.Monad
-+import qualified Control.Exception as E
- import System.FilePath
- import System.IO
--import System
-+import System.Exit
- import Text.Printf (printf, hPrintf)
-
- import qualified Ganeti.HTools.Luxi as Luxi
-@@ -56,8 +57,8 @@ import Ganeti.HTools.CLI
- import Ganeti.HTools.Utils (sepSplit, tryRead)
-
- -- | Error beautifier
--wrapIO :: IO (Result a) -> IO (Result a)
--wrapIO = flip catch (return . Bad . show)
-+wrapIO :: (Show a) => IO (Result a) -> IO (Result a)
-+wrapIO = flip (E.catch :: IO a -> (E.IOException -> IO a) -> IO a) (return . Bad . show )
-
- parseUtilisation :: String -> Result (String, DynUtil)
- parseUtilisation line =
-diff --git a/hail.hs b/hail.hs
-index 541e1a9..68f4488 100644
---- a/hail.hs
-+++ b/hail.hs
-@@ -27,10 +27,10 @@ module Main (main) where
-
- import Data.List
- import Data.Maybe (isJust, fromJust)
--import Monad
--import System (exitWith, ExitCode(..))
-+import Control.Monad
-+import System.Environment
-+import System.Exit
- import System.IO
--import qualified System
-
- import qualified Ganeti.HTools.Cluster as Cluster
-
-@@ -99,7 +99,7 @@ readRequest opts args = do
- -- | Main function.
- main :: IO ()
- main = do
-- cmd_args <- System.getArgs
-+ cmd_args <- getArgs
- (opts, args) <- parseOpts cmd_args "hail" options
-
- let shownodes = optShowNodes opts
-diff --git a/hbal.hs b/hbal.hs
-index 46cccf8..0254008 100644
---- a/hbal.hs
-+++ b/hbal.hs
-@@ -30,12 +30,12 @@ import Control.Exception (bracket)
- import Data.List
- import Data.Maybe (isJust, isNothing, fromJust)
- import Data.IORef
--import Monad
--import System (exitWith, ExitCode(..))
-+import Control.Monad
- import System.IO
-+import System.Exit
- import System.Posix.Process
- import System.Posix.Signals
--import qualified System
-+import System.Environment
-
- import Text.Printf (printf, hPrintf)
-
-@@ -223,7 +223,7 @@ runJobSet master fin_nl il cmd_jobs = do
- -- | Main function.
- main :: IO ()
- main = do
-- cmd_args <- System.getArgs
-+ cmd_args <- getArgs
- (opts, args) <- parseOpts cmd_args "hbal" options
-
- unless (null args) $ do
-diff --git a/hscan.hs b/hscan.hs
-index c14846f..d613f83 100644
---- a/hscan.hs
-+++ b/hscan.hs
-@@ -28,11 +28,11 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
- module Main (main) where
-
- import Data.Maybe (isJust, fromJust, fromMaybe)
--import Monad
--import System (exitWith, ExitCode(..))
-+import Control.Monad
-+import System.Environment
-+import System.Exit
- import System.IO
- import System.FilePath
--import qualified System
-
- import Text.Printf (printf)
-
-@@ -135,7 +135,7 @@ writeDataInner nlen name opts cdata fixdata = do
- -- | Main function.
- main :: IO ()
- main = do
-- cmd_args <- System.getArgs
-+ cmd_args <- getArgs
- (opts, clusters) <- parseOpts cmd_args "hscan" options
- let local = "LOCAL"
-
-diff --git a/hspace.hs b/hspace.hs
-index 57d0302..f207c67 100644
---- a/hspace.hs
-+++ b/hspace.hs
-@@ -29,10 +29,10 @@ import Data.Char (toUpper, isAlphaNum)
- import Data.List
- import Data.Maybe (isJust, fromJust)
- import Data.Ord (comparing)
--import Monad
--import System (exitWith, ExitCode(..))
-+import Control.Monad
-+import System.Exit
-+import System.Environment
- import System.IO
--import qualified System
-
- import Text.Printf (printf, hPrintf)
-
-@@ -207,7 +207,7 @@ printAllocationMap verbose msg nl ixes =
- -- | Main function.
- main :: IO ()
- main = do
-- cmd_args <- System.getArgs
-+ cmd_args <- getArgs
- (opts, args) <- parseOpts cmd_args "hspace" options
-
- unless (null args) $ do
-diff --git a/test.hs b/test.hs
-index 12aa50d..81838eb 100644
---- a/test.hs
-+++ b/test.hs
-@@ -29,7 +29,7 @@ import Data.IORef
- import Test.QuickCheck.Batch
- import System.IO
- import System.Exit
--import System (getArgs)
-+import System.Environment (getArgs)
-
- import Ganeti.HTools.QC
-
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch
deleted file mode 100644
index 2305aa5c6547..000000000000
--- a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Ganeti/HTools/QC.hs b/Ganeti/HTools/QC.hs
-index 534a7b1..6f99a96 100644
---- a/Ganeti/HTools/QC.hs
-+++ b/Ganeti/HTools/QC.hs
-@@ -753,3 +753,3 @@ prop_ClusterAllocBalance node =
- let nl = makeSmallCluster node count
-- (hnode, nl') = IntMap.deleteFindMax nl
-+ ((_k, hnode), nl') = IntMap.deleteFindMax nl
- il = Container.empty
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-ghc-7.10.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-ghc-7.10.patch
deleted file mode 100644
index 51c39fe5fce5..000000000000
--- a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-ghc-7.10.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/Ganeti/HTools/Types.hs b/Ganeti/HTools/Types.hs
-index 104bf64..8146870 100644
---- a/Ganeti/HTools/Types.hs
-+++ b/Ganeti/HTools/Types.hs
-@@ -65,2 +65,4 @@ import qualified Data.Map as M
- import qualified Text.JSON as JSON
-+import Control.Applicative
-+import Control.Monad
-
-@@ -221,2 +223,9 @@ data Result a
-
-+instance Functor Result where
-+ fmap = liftM
-+
-+instance Applicative Result where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad Result where
-@@ -252,2 +261,9 @@ data OpResult a = OpFail FailMode -- ^ Failed operation
-
-+instance Functor OpResult where
-+ fmap = liftM
-+
-+instance Applicative OpResult where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad OpResult where
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
deleted file mode 100644
index 7068c10267c8..000000000000
--- a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils multilib
-
-DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
-clusters"
-HOMEPAGE="http://www.ganeti.org/"
-SRC_URI="https://ganeti.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-DEPEND="dev-lang/ghc
- dev-haskell/json
- dev-haskell/curl
- dev-haskell/network
- dev-haskell/parallel"
-RDEPEND="${DEPEND}
- !<app-emulation/ganeti-2.4"
-DEPEND+=" test? ( dev-haskell/quickcheck:1 )"
-
-src_prepare() {
- # htools does not currently compile cleanly with ghc-6.12+, so remove this
- # for now
- sed -i -e "s:-Werror ::" Makefile
- # Workaround to skip pandoc
- sed -i -e "s:) man:):" Makefile
- epatch "${FILESDIR}"/${PN}-0.2.8-use-QC-1.patch #316629
- epatch "${FILESDIR}"/${PN}-0.3.1-base-4.patch #424299
- epatch "${FILESDIR}"/${PN}-0.3.1-ghc-7.10.patch
- epatch "${FILESDIR}"/${PN}-0.3.1-containers.patch
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dosbin hspace hscan hbal
- exeinto /usr/$(get_libdir)/ganeti/iallocators
- doexe hail
- doman man/*.1
- dodoc README NEWS AUTHORS
- use doc && dohtml -r apidoc/*
-}
diff --git a/app-emulation/ganeti-htools/metadata.xml b/app-emulation/ganeti-htools/metadata.xml
deleted file mode 100644
index 56690a9ca1ec..000000000000
--- a/app-emulation/ganeti-htools/metadata.xml
+++ /dev/null
@@ -1,27 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>virtualization@gentoo.org</email>
- <name>Gentoo Virtualization Project</name>
- </maintainer>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription lang="en">
- These are some simple cluster tools for fixing common allocation
- problems on Ganeti 2.0 clusters.
-
- Note that these tools are most useful for bigger cluster sizes
- (e.g. more than five or ten machines); at lower sizes, the computations
- they do can also be done manually.
-
- Most of the tools revolve around the concept of keeping the cluster N+1
- compliant: this means that in case of failure of any node, the instances
- affected can be failed over (via ``gnt-node failover`` or ``gnt-instance
- failover``) to their secondary node, and there is enough memory reserved
- for this operation without needing to shutdown other instances or
- rebalance the cluster.
- </longdescription>
-</pkgmetadata>