summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libvisio/Manifest1
-rw-r--r--media-libs/libvisio/libvisio-0.1.5.ebuild59
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild9
3 files changed, 65 insertions, 4 deletions
diff --git a/media-libs/libvisio/Manifest b/media-libs/libvisio/Manifest
index 88298e9c2a20..dcd05d530579 100644
--- a/media-libs/libvisio/Manifest
+++ b/media-libs/libvisio/Manifest
@@ -1,3 +1,4 @@
DIST libvisio-0.0.30.tar.xz 384508 SHA256 e7be89fdef23483deea53a557fe023c9f6b59e0f7bb5ba4f42b5909c86cc11f9 SHA512 d0261f30ca9065873aa498f7594a638d0a90dadd4df609a91e746579d14b5f1f18aa4e4812d25870b390f2df59ffa8f8a4d76618c6e71539023b7610044c9d21 WHIRLPOOL 1e328569f3e810c6cc1399015b7fb5b4aa206e0127109efaad23163fba8d45a4a74945ff6cca3dcc883dcd1248be69149383a2d9f44fb5be213ebfcd2574a92e
DIST libvisio-0.1.1.tar.xz 412752 SHA256 4b510168d1465516fdf6e57c01e2f9eae1fc0ae232c74e44e70693bbc49227f1 SHA512 c17c3a94985bd4c6fb10fc27d1b61ac812d5b663d123d2a5a5089f9297d39c53befffd563e6367aa024df7f69c03a1cfa41edef71c824cf03e26e3b01987dd38 WHIRLPOOL 47b81e6f4ad9f6267113d259f3d9514751fd73a731ded9b265dddbaa918bee5be1a1580ced9ceb287822ee8a67841f15ca06e04d300212301ae5549625589cfa
DIST libvisio-0.1.3.tar.xz 479592 SHA256 943e03b1e6c969af4c2133a6671c9630adf3aaf8d460156744a28f58c9f47cd8 SHA512 aa7ea66d30b54e70acd6684a861923dd5979025e5fda12e1e777c6e7a461f9691f2df1dd67ea4599dbb7e0293df0eee9dc9848f79067c4058afb090717489d35 WHIRLPOOL db483c052f69d1874681d36bac98bb7d65f6fd1cd2e8650fc2be0be1705b51dc43a79ad306eafacf11f4463e2e1a18776c3b5e5b0aefc7f92f5eb718aee50e04
+DIST libvisio-0.1.5.tar.xz 504196 SHA256 430a067903660bb1b97daf4b045e408a1bb75ca45e615cf05fb1a4da65fc5a8c SHA512 094ab546f650840d52fc34c1b105eff139d2f6e4d5cab7c9c99f8387ece0d0c6b02ec1376b3281d56a901bac016c2a024bb708c065b8b5d9404104e6494b5fab WHIRLPOOL ee2c67f357a3cc907b78e3cb8c6001ff1da2529d61f691dbad634f15639ff22a72bbec7deae08166ccaa4acfb730a826d96b9f1567e1c7c830ded1dc130388f3
diff --git a/media-libs/libvisio/libvisio-0.1.5.ebuild b/media-libs/libvisio/libvisio-0.1.5.ebuild
new file mode 100644
index 000000000000..c2ac25fe1375
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.3-tests-without-tools.patch" )
+
+src_prepare() {
+ eapply "${PATCHES[@]}"
+ eapply_user
+ [[ -d m4 ]] || mkdir "m4"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
index 591d1b34eb80..0adbb1cda8e2 100644
--- a/media-libs/libvisio/libvisio-9999.ebuild
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit base eutils
+inherit eutils
[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library parsing the visio documents"
@@ -25,6 +25,7 @@ RDEPEND="
sys-libs/zlib
"
DEPEND="${RDEPEND}
+ dev-lang/perl
>=dev-libs/boost-1.46
dev-util/gperf
sys-devel/libtool
@@ -34,8 +35,8 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ eapply_user
[[ -d m4 ]] || mkdir "m4"
- base_src_prepare
[[ ${PV} == 9999 ]] && eautoreconf
}