summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/poezio/Manifest1
-rw-r--r--net-im/poezio/poezio-0.13.1-r2.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/net-im/poezio/Manifest b/net-im/poezio/Manifest
index 02b8eba1a8a6..89fdd00059f4 100644
--- a/net-im/poezio/Manifest
+++ b/net-im/poezio/Manifest
@@ -1,2 +1 @@
-DIST poezio-0.13.1.tar.gz 632572 BLAKE2B e8d3d34c5ca8d236a5a434b4b339cab5ea7286c60db3ef5a6012d406848537b587e834b86f7b6049ee8e637a82e883b2d874134bc1f7d64106e0b0f81aab218f SHA512 6c211ef0fa2fc4bd4cce6ab896166eec6bcdc16ad9e774f4d6bf261b404c9ef68b18d934097da0e165b0cce9bd7779da520ac9c3eac30ccf8280f98ef6aa19c6
DIST poezio-0.14.tar.gz 662379 BLAKE2B 467741d82945c084c79811d41ff85358ad236d0dcefca7e6f1f8ed5d78aa127f800d2370d624ebaf9e2eb20e1038f280c2e874694ea2b86965fe329b82c4b7d8 SHA512 6e68954a918c645592e2d2f8a265e2f2445a39e256c0525a5517e758a90cc404e066cc08d67ad0f8a3c7d6f3efd61f13a776737d110dd23df7a5f7fab54fc6b5
diff --git a/net-im/poezio/poezio-0.13.1-r2.ebuild b/net-im/poezio/poezio-0.13.1-r2.ebuild
deleted file mode 100644
index a43f1e0504f7..000000000000
--- a/net-im/poezio/poezio-0.13.1-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1 optfeature xdg
-
-DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
-HOMEPAGE="https://poez.io/"
-LICENSE="ZLIB"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
- inherit git-r3
-
- # We build the html documentation using sphinx.
- BDEPEND="dev-python/sphinx"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-RDEPEND="
- dev-python/aiodns[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/slixmpp-1.5.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/Do-not-install-man-pages-and-files-in-usr-share-poez.patch"
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- default
- # Delete unmaintained plugin which requires an excessive external dep
- rm plugins/mpd_client.py || die
-}
-
-src_compile() {
- distutils-r1_src_compile
-
- if [[ -n "${EGIT_REPO_URI}" ]]; then
- emake -C doc html
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- doman data/poezio.1 data/poezio_logs.1
-
- if [[ -n "${EGIT_REPO_URI}" ]]; then
- docinto html
- dodoc -r doc/build/html/*
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "screen autoaway support" dev-python/pyinotify
-}