summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.10.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 7188ac518875..722f91486495 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1 @@
-DIST borgmatic-1.5.10.tar.gz 71743 BLAKE2B b2b5f9135a15730ca7ddddeaa7f621f82207f1dcf383c3be7459eb39dbffc85a310184a4ddce3fb0bd47aa213cb588eb3f3e2f73418659330a421b7da5b87698 SHA512 52436535810ce42f5ab30ae8a4705005e8c7a5d91d52520aab4160320215196cdc088dfae1a21a0d65d0161fb2bb3c9b984cfe2cb5204f7b9bd0ed27c3a38c5b
DIST borgmatic-1.5.12.tar.gz 72964 BLAKE2B d71537eed019b10c3257d4b068c31aff63919e0cdb068b49c2ed92d2e97d37b8735f30b1225fb453e79372aeab49817e9200770aac4cc0f80c0bac14e84678d1 SHA512 67c7c7683e9fb7dd0321b3db6887212b040596f1d7e767cceeae6fa4cc02bb0a46344befbbc7a33b454a4692b04ae88d9031f71867788a94f771999d885112d5
diff --git a/app-backup/borgmatic/borgmatic-1.5.10.ebuild b/app-backup/borgmatic/borgmatic-1.5.10.ebuild
deleted file mode 100644
index 0566308b2aee..000000000000
--- a/app-backup/borgmatic/borgmatic-1.5.10.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
-HOMEPAGE="https://torsion.org/borgmatic/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-
-# Fails due to problems with dev-python/flexmock-0.10.4; see Bug #740128
-RESTRICT="test"
-
-# borg is called as an external tool, hence no pythonic stuff
-RDEPEND="app-backup/borgbackup
- $(python_gen_cond_dep '
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.17.0[${PYTHON_USEDEP}]
- ')"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/flexmock[${PYTHON_USEDEP}]
- ')
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
- "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Unlike the other two test files in integration/commands, which use the
- # relevant modules' respective APIs, test_borgmatic.py tries to call the
- # 'borgmatic' executable - which by the time we execute src_test will
- # not have been created yet. distutils_install_for_testing would likely
- # take care of this - but between the aforementioned behaviour inconsistency
- # and the fact the only test run from this file as of version 1.5.1 is the
- # parsing of contents of 'borgmatic --version', just skip it for now.
- rm -f "${S}"/tests/integration/commands/test_borgmatic.py
-}
-
-src_install() {
- distutils-r1_src_install
- systemd_dounit sample/systemd/borgmatic.{service,timer}
- keepdir /etc/borgmatic
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "To generate a sample configuration file, run:"
- elog " generate-borgmatic-config"
- fi
- elog
- elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
-}