summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/photivo/Manifest1
-rw-r--r--media-gfx/photivo/metadata.xml16
-rw-r--r--media-gfx/photivo/photivo-0_pre20131115.ebuild69
-rw-r--r--media-gfx/photivo/photivo-9999.ebuild70
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 161 deletions
diff --git a/media-gfx/photivo/Manifest b/media-gfx/photivo/Manifest
deleted file mode 100644
index bc561190273e..000000000000
--- a/media-gfx/photivo/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST photivo-0_pre20131115.tar.gz 3145008 BLAKE2B 61051c1f1c49eb3e7ae3c350b27cc4336256a2a299bc84d621f290e4fca6f82c7008dc9f32d0472b2a6ac58c088cfcfa861d06d6a80b5435eeb107fe8f8043e9 SHA512 b98d2dced306325b5ab116c4ba170404a6956d081128095b5315f3b061797290b5a305da73ede9f496659b2b1cc8090cd2f300cfbd311c69db59c8425bd2e047
diff --git a/media-gfx/photivo/metadata.xml b/media-gfx/photivo/metadata.xml
deleted file mode 100644
index 3910c7f010a9..000000000000
--- a/media-gfx/photivo/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>opensource@andmarios.com</email>
- <name>Marios Andreopoulos</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="google-code">photivo</remote-id>
- <bugs-to>https://code.google.com/p/photivo/issues/list</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/media-gfx/photivo/photivo-0_pre20131115.ebuild b/media-gfx/photivo/photivo-0_pre20131115.ebuild
deleted file mode 100644
index f258013d4bf7..000000000000
--- a/media-gfx/photivo/photivo-0_pre20131115.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit qt4-r2
-
-DESCRIPTION="Photo processor for RAW and Bitmap images"
-HOMEPAGE="http://www.photivo.org"
-SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gimp"
-
-RDEPEND="dev-qt/qtcore:4
- dev-qt/qtgui:4
- || ( virtual/jpeg:62 media-libs/jpeg:62 )
- media-gfx/exiv2
- media-libs/tiff
- media-libs/libpng
- media-libs/cimg
- media-libs/lcms:2
- >=media-libs/lensfun-0.2.8-r1
- sci-libs/fftw:3.0
- media-libs/liblqr
- media-gfx/graphicsmagick[q16,-lcms]
- gimp? ( media-gfx/gimp )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}-${PV/0_pre/}
-
-src_prepare() {
- # remove ccache dependency and fix lensfun header path
- local File
- for File in $(find "${S}" -type f); do
- if grep -sq ccache ${File}; then
- sed -e 's/ccache//' -i "${File}"
- fi
- if grep -sq "lensfun.h" ${File}; then
- sed -e 's/lensfun\.h/lensfun\/lensfun.h/' -i ${File}
- fi
- done
-
- # useless check (no pkgconfig file is provided)
- sed -e "/PKGCONFIG += CImg/d" \
- -i photivoProject/photivoProject.pro || die
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local config="WithSystemCImg"
- if use gimp ; then
- config+=" WithGimp"
- fi
-
- eqmake4 "CONFIG+=${config}"
-}
-
-src_install() {
- qt4-r2_src_install
-
- if use gimp; then
- exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
- doexe ptGimp
- doexe "mm extern photivo.py"
- fi
-}
diff --git a/media-gfx/photivo/photivo-9999.ebuild b/media-gfx/photivo/photivo-9999.ebuild
deleted file mode 100644
index 8bfa2a2968b7..000000000000
--- a/media-gfx/photivo/photivo-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit qt4-r2 mercurial
-
-DESCRIPTION="Photo processor for RAW and Bitmap images"
-HOMEPAGE="http://www.photivo.org"
-EHG_REPO_URI="https://bitbucket.org/Photivo/photivo"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="gimp"
-
-RDEPEND="dev-qt/qtcore:4
- dev-qt/qtgui:4
- || ( virtual/jpeg:62 media-libs/jpeg:62 )
- media-gfx/exiv2
- media-libs/cimg
- media-libs/lcms:2
- media-libs/lensfun
- sci-libs/fftw:3.0
- media-libs/liblqr
- media-gfx/graphicsmagick[q16,-lcms]
- gimp? ( media-gfx/gimp )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # remove ccache dependency
- local File
- for File in $(find "${S}" -type f); do
- if grep -sq ccache ${File}; then
- sed -e 's/ccache//' -i "${File}" || die
- fi
- done
-
- # bug 560120 - fix includes for lensfun.h
- sed -s -e 's:lensfun.h:lensfun\/lensfun.h:' \
- -i ReferenceMaterial/LensFunSample.c \
- -i Sources/ptConstants.h \
- -i Sources/ptImage.h \
- -i Sources/ptImage_Lensfun.cpp \
- -i Sources/ptLensfun.h || die
-
- # useless check (no pkgconfig file is provided)
- sed -e "/PKGCONFIG += CImg/d" \
- -i photivoProject/photivoProject.pro || die
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local config="WithSystemCImg"
- if use gimp ; then
- config+=" WithGimp"
- fi
-
- eqmake4 "CONFIG+=${config}"
-}
-
-src_install() {
- qt4-r2_src_install
-
- if use gimp; then
- exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
- doexe ptGimp
- doexe "mm extern photivo.py"
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index d81d243b1b92..ff6c36c5ebf7 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -599,11 +599,6 @@ media-gfx/qosmic
# Bug 649764 Removal in 30 days.
dev-db/maxscale
-# Andreas Sturmlechner <asturm@gentoo.org> (06 Mar 2018)
-# Maintainer not responding, depends on deprecated Qt4.
-# Masked for removal in 30 days. Bug 598651, 635192, 644396
-media-gfx/photivo
-
# Andreas K. Hüttel <dilfridge@gentoo.org> (03 Mar 2018)
# Fails to build without rpc support in glibc (bug 631044);
# no maintainer, requires obsolete hardware. Removal in