summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/qhull/metadata.xml36
-rw-r--r--media-libs/qhull/qhull-2020.2.ebuild4
2 files changed, 22 insertions, 18 deletions
diff --git a/media-libs/qhull/metadata.xml b/media-libs/qhull/metadata.xml
index c6a69293d768..429d8032e635 100644
--- a/media-libs/qhull/metadata.xml
+++ b/media-libs/qhull/metadata.xml
@@ -1,20 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
- Qhull computes the convex hull, Delaunay triangulation, Voronoi
- diagram, halfspace intersection about a point, furthest-site
- Delaunay triangulation, and furthest-site Voronoi diagram. The
- source code runs in 2-d, 3-d, 4-d, and higher dimensions. Qhull
- implements the Quickhull algorithm for computing the convex hull. It
- handles roundoff errors from floating point arithmetic. It computes
- volumes, surface areas, and approximations to the convex hull.
- Qhull does not support constrained Delaunay triangulations,
- triangulation of non-convex surfaces, mesh generation of non-convex
- objects, or medium-sized inputs in 9-D and higher.
-</longdescription>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Qhull computes the convex hull, Delaunay triangulation, Voronoi
+ diagram, halfspace intersection about a point, furthest-site
+ Delaunay triangulation, and furthest-site Voronoi diagram. The
+ source code runs in 2-d, 3-d, 4-d, and higher dimensions. Qhull
+ implements the Quickhull algorithm for computing the convex hull. It
+ handles roundoff errors from floating point arithmetic. It computes
+ volumes, surface areas, and approximations to the convex hull.
+ Qhull does not support constrained Delaunay triangulations,
+ triangulation of non-convex surfaces, mesh generation of non-convex
+ objects, or medium-sized inputs in 9-D and higher.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/qhull/qhull/issues</bugs-to>
+ <remote-id type="github">qhull/qhull</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-libs/qhull/qhull-2020.2.ebuild b/media-libs/qhull/qhull-2020.2.ebuild
index 25c4e7d784dd..31da6061ee1c 100644
--- a/media-libs/qhull/qhull-2020.2.ebuild
+++ b/media-libs/qhull/qhull-2020.2.ebuild
@@ -20,8 +20,8 @@ src_prepare() {
if ! use doc ; then
sed -i \
-e '/^install(DIRECTORY html/d' \
- -e '/^[[:blank:]]*index.htm/d' \
- CMakeLists.txt || die
+ -e '/^[[:blank:]]*index.htm/d' \
+ CMakeLists.txt || die
fi
cmake_src_prepare