summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/ppcoind/Manifest1
-rw-r--r--net-p2p/ppcoind/files/ppcoin.conf8
-rw-r--r--net-p2p/ppcoind/files/ppcoin.confd10
-rw-r--r--net-p2p/ppcoind/files/ppcoin.initd104
-rw-r--r--net-p2p/ppcoind/files/ppcoin.initd-r128
-rw-r--r--net-p2p/ppcoind/files/ppcoin.service30
-rw-r--r--net-p2p/ppcoind/files/ppcoind-0.4.0-boost_chrono.patch10
-rw-r--r--net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch11
-rw-r--r--net-p2p/ppcoind/files/ppcoind.logrotate7
-rw-r--r--net-p2p/ppcoind/metadata.xml11
-rw-r--r--net-p2p/ppcoind/ppcoind-0.4.0-r1.ebuild116
-rw-r--r--profiles/package.mask5
12 files changed, 0 insertions, 341 deletions
diff --git a/net-p2p/ppcoind/Manifest b/net-p2p/ppcoind/Manifest
deleted file mode 100644
index c62698a76b98..000000000000
--- a/net-p2p/ppcoind/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ppcoin-0.4.0.tar.gz 12652477 BLAKE2B fbb55c393feea8341ebe0cdf3c48730b63efd15023bb849b9b2f93e8f0a19ab4ecf17802184f76731708fc89a338f946481691a956a58749baa86cf6bd698d5f SHA512 755890e32048f8cdfb9f93706eff952ae2876be394c0a76cf93a79562a28fe03c74c829c97b9234fbc27c03e4b706373f55723564ca7b91a4ff908ca072299c4
diff --git a/net-p2p/ppcoind/files/ppcoin.conf b/net-p2p/ppcoind/files/ppcoin.conf
deleted file mode 100644
index c6a55f3d9133..000000000000
--- a/net-p2p/ppcoind/files/ppcoin.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-# http://www.bitcoin.org/smf/index.php?topic=644.0
-#rpcuser=
-#rpcpassword=
-
-
-
-
-
diff --git a/net-p2p/ppcoind/files/ppcoin.confd b/net-p2p/ppcoind/files/ppcoin.confd
deleted file mode 100644
index 81fbf49e9f38..000000000000
--- a/net-p2p/ppcoind/files/ppcoin.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-# Config file for /etc/init.d/ppcoind
-
-# owner of ppciond process (don't change, must be existing)
-PPCOIN_USER="ppcoin"
-
-# See http://www.bitcoin.org/smf/index.php?topic=1063
-PPCOIN_OPTS="${PPCOIN_OPTS}"
-
-# nice level
-NICELEVEL="19"
diff --git a/net-p2p/ppcoind/files/ppcoin.initd b/net-p2p/ppcoind/files/ppcoin.initd
deleted file mode 100644
index e739dc7dba4e..000000000000
--- a/net-p2p/ppcoind/files/ppcoin.initd
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/sbin/openrc-run
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-VARDIR="/var/lib/ppcoin"
-CONFFILE="${VARDIR}/.ppcoin/ppcoin.conf"
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [[ "${PPCOIN_USER}" == "" ]] ; then
- eerror "Please edit /etc/conf.d/ppcoind"
- eerror "A user must be specified to run ppcoind as that user."
- eerror "Modify USER to your needs (you may also add a group after a colon)"
- return 1
- fi
- if ! `getent passwd | cut -d ':' -f 1 | grep $( echo "${PPCOIN_USER}" | cut -d ':' -f 1 ) -sq` ; then
- eerror "Please edit /etc/conf.d/ppcoind"
- eerror "Specified user must exist!"
- return 1
- fi
- if `echo "${PPCOIN_USER}" | grep ':' -sq` ; then
- if ! `cut -d ':' -f 1 /etc/group | grep $( echo "${PPCOIN_USER}" | cut -d ':' -f 2 ) -sq` ; then
- eerror "Please edit /etc/conf.d/ppcoind"
- eerror "Specified group must exist!"
- return 1
- fi
- fi
- if ! grep -q '^rpcpassword=' "${CONFFILE}"; then
- eerror "Please edit `readlink -f ${CONFFILE}`"
- eerror "There must be at least a line assigning rpcpassword=something-secure"
- return 1
- fi
- if ! stat -Lc '%a' "${CONFFILE}" | grep -q '^[4567]00$'; then
- eerror "`readlink -f ${CONFFILE}` should not be readable by other users"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting PPcoind daemon"
-
- pkg-config openrc
- if [ $? = 0 ]; then
- start_openrc
- else
- start_baselayout
- fi
-}
-
-stop() {
- ebegin "Stopping PPcoin daemon"
-
- pkg-config openrc
- if [ $? = 0 ]; then
- stop_openrc
- else
- stop_baselayout
- fi
-}
-
-start_openrc() {
- start-stop-daemon \
- --start --user "${PPCOIN_USER}" --name ppcoind \
- --pidfile /var/run/ppcoind.pid --make-pidfile \
- --env HOME="${VARDIR}" --exec /usr/bin/ppcoind \
- --nicelevel "${NICELEVEL}" \
- --background \
- --wait 2000 \
- -- ${PPCOIN_OPTS}
- eend $?
-}
-
-stop_openrc() {
- start-stop-daemon --stop --user "${PPCOIN_USER}" \
- --name ppcoind --pidfile /var/run/ppcoind.pid \
- --wait 30000 \
- --progress
- eend $?
-}
-
-start_baselayout() {
- start-stop-daemon \
- --start --user "${PPCOIN_USER}" --name ppcoind \
- --pidfile /var/run/ppcoind.pid --make-pidfile \
- --env HOME="${VARDIR}" --exec /usr/bin/ppcoind \
- --chuid "${PPCOIN_USER}" \
- --nicelevel "${NICELEVEL}" \
- --background \
- -- ${PPCOIN_OPTS}
- eend $?
-}
-
-stop_baselayout() {
- start-stop-daemon \
- --stop \
- --user "${PPCOIN_USER}" \
- --name ppcoind \
- --pidfile /var/run/ppcoind.pid
- eend $?
-}
diff --git a/net-p2p/ppcoind/files/ppcoin.initd-r1 b/net-p2p/ppcoind/files/ppcoin.initd-r1
deleted file mode 100644
index 8023f1f0d378..000000000000
--- a/net-p2p/ppcoind/files/ppcoin.initd-r1
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-vardir="/var/lib/ppcoin"
-conffile="${vardir}/.ppcoin/ppcoin.conf"
-ppcoind_user="${PPCOIN_USER:-nobody:nobody}"
-
-description="Cryptocurrency forked from Bitcoin which aims to be energy efficiency."
-pidfile="/run/${SVCNAME}.pid"
-command="/usr/bin/ppcoind"
-command_args="${PPCOIN_OPTS}"
-command_background="true"
-start_stop_daemon_args="-u ${ppcoind_user} -e HOME=${vardir} -N ${NICELEVEL:-0} -w 2000"
-
-depend() {
- need net
-}
-
-start_pre() {
- checkpath -f -o ${ppcoind_user} -m 0400 ${conffile} || return 1
-
- if ! grep -q '^rpcpassword=' "${conffile}"; then
- eerror "Please edit `readlink -f ${conffile}`"
- eerror "There must be at least a line assigning rpcpassword=something-secure"
- return 1
- fi
-}
diff --git a/net-p2p/ppcoind/files/ppcoin.service b/net-p2p/ppcoind/files/ppcoin.service
deleted file mode 100644
index 3a83178fe04e..000000000000
--- a/net-p2p/ppcoind/files/ppcoin.service
+++ /dev/null
@@ -1,30 +0,0 @@
-# It's not recommended to modify this file in-place, because it will be
-# overwritten during package upgrades. If you want to customize, the
-# best way is to create file
-# "/etc/systemd/system/ppcoind.service.d/*.conf"
-# containing your changes
-
-# For example, if you want to change some daemon and/or unit options,
-# create a file named
-# "/etc/systemd/system/ppcoind.service.d/myopts.conf"
-# containing:
-# [Service]
-# Environment="PPCOIN_OPTS=-debug -logtimestamps"
-# Nice=10
-# This will override the setting appearing below.
-
-# Note that almost all daemon options could be specified in
-# /etc/ppcoin/ppcoin.conf
-
-[Unit]
-Description=PPcoin Daemon
-After=network.target
-
-[Service]
-User=ppcoin
-Environment=PPCOIN_OPTS=
-ExecStart=/usr/bin/ppcoind -daemon=0 $PPCOIN_OPTS
-ExecReload=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-p2p/ppcoind/files/ppcoind-0.4.0-boost_chrono.patch b/net-p2p/ppcoind/files/ppcoind-0.4.0-boost_chrono.patch
deleted file mode 100644
index 390d5c7c94b1..000000000000
--- a/net-p2p/ppcoind/files/ppcoind-0.4.0-boost_chrono.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/makefile.unix
-+++ b/src/makefile.unix
-@@ -30,6 +30,7 @@
- -l boost_filesystem$(BOOST_LIB_SUFFIX) \
- -l boost_program_options$(BOOST_LIB_SUFFIX) \
- -l boost_thread$(BOOST_LIB_SUFFIX) \
-+ -l boost_chrono$(BOOST_LIB_SUFFIX) \
- -l db_cxx$(BDB_LIB_SUFFIX) \
- -l ssl \
- -l crypto
diff --git a/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch b/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch
deleted file mode 100644
index 76bad3feb5a4..000000000000
--- a/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/net.cpp
-+++ b/src/net.cpp
-@@ -51,7 +51,7 @@ CAddress addrLocalHost(CService("0.0.0.0", 0), nLocalServices);
- CAddress addrSeenByPeer(CService("0.0.0.0", 0), nLocalServices);
- static CNode* pnodeLocalHost = NULL;
- uint64 nLocalHostNonce = 0;
--array<int, THREAD_MAX> vnThreadsRunning;
-+boost::array<int, THREAD_MAX> vnThreadsRunning;
- static SOCKET hListenSocket = INVALID_SOCKET;
- CAddrMan addrman;
-
diff --git a/net-p2p/ppcoind/files/ppcoind.logrotate b/net-p2p/ppcoind/files/ppcoind.logrotate
deleted file mode 100644
index 4ea060b0f0f7..000000000000
--- a/net-p2p/ppcoind/files/ppcoind.logrotate
+++ /dev/null
@@ -1,7 +0,0 @@
-/var/lib/ppcoin/.ppcoin/debug.log {
- weekly
- sharedscripts
- postrotate
- killall -HUP ppcoind
- endscript
-}
diff --git a/net-p2p/ppcoind/metadata.xml b/net-p2p/ppcoind/metadata.xml
deleted file mode 100644
index f08d8cf453eb..000000000000
--- a/net-p2p/ppcoind/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="logrotate">Use app-admin/logrotate for rotating logs</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">ppcoin</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-p2p/ppcoind/ppcoind-0.4.0-r1.ebuild b/net-p2p/ppcoind/ppcoind-0.4.0-r1.ebuild
deleted file mode 100644
index 08d250f53efe..000000000000
--- a/net-p2p/ppcoind/ppcoind-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DB_VER="4.8"
-
-inherit db-use eutils systemd user
-
-MyPV="${PV/_/-}"
-MyPN="ppcoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="Cryptocurrency forked from Bitcoin which aims to be energy efficiency"
-HOMEPAGE="https://peercoin.net/"
-SRC_URI="mirror://sourceforge/${MyPN}/${MyP}-linux.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- dev-libs/boost:=[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-DOCS=( ../README README.md )
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc6.patch
- "${FILESDIR}"/${P}-boost_chrono.patch
-)
-
-S="${WORKDIR}/${MyP}-linux/src"
-
-pkg_setup() {
- local UG='ppcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/ppcoin "${UG}"
-}
-
-src_configure() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- if use upnp; then
- OPTS+=("USE_UPNP=1")
- else
- OPTS+=("USE_UPNP=-")
- fi
-
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -C src -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-#Tests are broken
-#src_test() {
-# cd src || die
-# emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_ppcoin
-# ./test_ppcoin || die 'Tests failed'
-#}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/ppcoin
- doins "${FILESDIR}/ppcoin.conf"
- fowners ppcoin:ppcoin /etc/ppcoin/ppcoin.conf
- fperms 600 /etc/ppcoin/ppcoin.conf
-
- newconfd "${FILESDIR}/ppcoin.confd" ${PN}
- newinitd "${FILESDIR}/ppcoin.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/ppcoin.service"
-
- keepdir /var/lib/ppcoin/.ppcoin
- fperms 700 /var/lib/ppcoin
- fowners ppcoin:ppcoin /var/lib/ppcoin/
- fowners ppcoin:ppcoin /var/lib/ppcoin/.ppcoin
- dosym /etc/ppcoin/ppcoin.conf /var/lib/ppcoin/.ppcoin/ppcoin.conf
-
- newman contrib/debian/manpages/bitcoind.1 ppcoind.1
- newman contrib/debian/manpages/bitcoin.conf.5 ppcoin.conf.5
-
- einstalldocs
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,gitian-descriptors,gitian-downloader,pyminer,wallettools}
-
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/ppcoind.logrotate" ppcoind
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 1645582903e6..cae14e73b566 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -162,11 +162,6 @@ dev-java/ant-trax
app-admin/localepurge
# Pacho Ramos <pacho@gentoo.org> (11 Nov 2018)
-# Unmaintained, really old version in the tree with someone needs to get
-# bumped (#622572). Removal in a month.
-net-p2p/ppcoind
-
-# Pacho Ramos <pacho@gentoo.org> (11 Nov 2018)
# Fails to build (#662000), not compatible with kernel-4, use kernel driver rtsx_pci
# instead. Removal in a month.
sys-block/rts_pstor