summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/qudos/Manifest2
-rw-r--r--games-fps/qudos/qudos-0.40.1.ebuild56
2 files changed, 23 insertions, 35 deletions
diff --git a/games-fps/qudos/Manifest b/games-fps/qudos/Manifest
index 4c5257af06dc..b7fc28b47dcd 100644
--- a/games-fps/qudos/Manifest
+++ b/games-fps/qudos/Manifest
@@ -1,2 +1,2 @@
DIST QuDos-0.40.1-src.tar.bz2 2031636 SHA256 90d8dbbbe4e006b4233b9c8c20bc3da5c240dde8fdf17ccf43ca533d296aa21a SHA512 97b9c6bac0d09c060ab33174604deb2781f0ebdc48b00bd0bc402523fb04cdf84edd8abc18507bba8c7e616f6d460a1de6debc96ec39bb5562b20a7f06eea734 WHIRLPOOL 623456b47dfefc389ceadf267369221c2a89a934597fbc5e951c9728d6947a982525884803cfae6a59ede682c637bfba2f97f0c3e2c98579fce63dfe71161fca
-DIST QuDos-0.40.1.pk3 5253128 SHA256 c02e0df50785d5b360ec5435e2fd3d31b337f28f676b7af141a8e2664f518f1c SHA512 69d1e752c32e763f0452f41856fbb9833676dfd27337633c65666b47be13db48be7ad6f81054b180a3fdc43d3952f3bbe632df12fa0a8e86be14c48c2d8daec5 WHIRLPOOL 33d54cadce0d5d3fd4353838dcd9719443f3fc01f5bb859f80aae105389990c62cc8ee5576eb81098ccce5320d7591b9c955f9e82c61461ec217e01034a939d4
+DIST QuDos-0.40.1.pk3 4210489 SHA256 c6f4dec4b0499b7b9d311d0d2a438358a205d4203eeee1b49f5695e5e14859ca SHA512 19c3c6b3d17cbd9642320d8eb7a83d667afeafd0ee5eb818e9f07be71e2ab69182474c1f529ecbcfcfa59590bafedb0de3c70dfff10e4bc7a6e07a1546f27d4b WHIRLPOOL 53d571d352f2f184fad9fcefd45a77e4d703e3338b5ec4baa77d0f46fb669d95164a2fa33dd80cb7083c40dd86da54cf4a0bea6e5d5dbb9253c3c9b53a44f86c
diff --git a/games-fps/qudos/qudos-0.40.1.ebuild b/games-fps/qudos/qudos-0.40.1.ebuild
index 32e875905a41..2b2f07496e88 100644
--- a/games-fps/qudos/qudos-0.40.1.ebuild
+++ b/games-fps/qudos/qudos-0.40.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,18 +12,19 @@ MY_PN="quake2"
DESCRIPTION="Enhanced Quake 2 engine"
HOMEPAGE="http://qudos.quakedev.com/"
SRC_URI="http://qudos.quakedev.com/linux/${MY_PN}/engines/QuDos/${FILE_STEM}.tar.bz2
- http://qudos.quakedev.com/linux/${MY_PN}/engines/QuDos/${PK3_FILE}"
+ https://github.com/ZwS/qudos/raw/master/quake2/baseq2/qudos.pk3 -> ${PK3_FILE}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa cdinstall debug dedicated demo dga ipv6 joystick mods opengl qmax oss sdl textures"
+IUSE="cdinstall debug dedicated demo dga ipv6 joystick mods opengl qmax oss sdl textures"
-UIDEPEND="alsa? ( media-libs/alsa-lib )
- opengl? (
+DEPEND="opengl? (
+ virtual/opengl
+ virtual/glu )
+ sdl? ( media-libs/libsdl[joystick?,opengl,sound,video]
virtual/opengl
virtual/glu )
- sdl? ( media-libs/libsdl )
virtual/jpeg:0
media-libs/libogg
media-libs/libpng:0
@@ -33,11 +34,10 @@ UIDEPEND="alsa? ( media-libs/alsa-lib )
x11-libs/libXext
x11-libs/libXxf86dga
x11-libs/libXxf86vm"
-RDEPEND="${UIDEPEND}
+RDEPEND="${DEPEND}
cdinstall? ( games-fps/quake2-data )
- demo? ( games-fps/quake2-demodata )
+ demo? ( games-fps/quake2-demodata[symlink] )
textures? ( games-fps/quake2-textures )"
-DEPEND="${UIDEPEND}"
S=${WORKDIR}/${FILE_STEM}
dir=${GAMES_DATADIR}/${MY_PN}
@@ -71,19 +71,12 @@ pkg_setup() {
snd_drv=""
[[ -z "${snd_drv}" ]] && use oss && snd_drv="oss"
[[ -z "${snd_drv}" ]] && use sdl && snd_drv="sdl"
- [[ -z "${snd_drv}" ]] && use alsa && snd_drv="alsa"
# Default if nothing else chosen
[[ -z "${snd_drv}" ]] && snd_drv="oss"
if default_client ; then
elog "Selected the ${snd_drv} sound driver as the default."
echo
- if [[ "${snd_drv}" = "alsa" ]] ; then
- ewarn "The ALSA sound driver for this game is incomplete."
- # OSS is the default sound driver in the Makefile
- ewarn "The 'oss' USE flag is recommended instead."
- echo
- fi
fi
}
@@ -95,25 +88,30 @@ src_prepare() {
rm docs/gnu.txt
# Change default sound driver and its location
- sed -i src/client/snd_dma.c \
+ sed -i \
-e "s:\"oss\":\"${snd_drv}\":" \
-e "s:\"\./snd:\"$(games_get_libdir)/${PN}/snd:" \
- || die "sed snd_dma.c failed"
+ src/client/snd_dma.c || die
sed -i \
-e 's:jpeg_mem_src:qudos_jpeg_mem_src:g' \
src/ref_gl/gl_image.c || die
- has_version '>=sys-libs/zlib-1.2.5.1-r1' && \
- sed -i -e '1i#define OF(x) x' src/qcommon/unzip/ioapi.h
+ if has_version '>=sys-libs/zlib-1.2.5.1-r1' ; then
+ sed -i \
+ -e '1i#define OF(x) x' \
+ src/qcommon/unzip/ioapi.h || die
+ fi
+ sed -i -e '106,119 s/CFL/LED/' Makefile || die
epatch \
"${FILESDIR}"/${P}-libpng15.patch \
"${FILESDIR}"/${P}-gnusource.patch
}
+
src_compile() {
- yesno() { use $1 && echo YES || echo NO ; }
+ yesno() { usex $1 YES NO; }
local client="YES"
default_client || client="NO"
@@ -121,12 +119,12 @@ src_compile() {
local type="release"
use debug && type="debug"
- emake -j1 \
+ emake \
BUILD_QUAKE2="${client}" \
BUILD_DEDICATED=$(yesno dedicated) \
BUILD_GLX=$(yesno opengl) \
BUILD_SDLGL=$(yesno sdl) \
- BUILD_ALSA_SND=$(yesno alsa) \
+ BUILD_ALSA_SND=NO \
BUILD_SDL_SND=$(yesno sdl) \
BUILD_OSS_SND=$(yesno oss) \
WITH_XMMS=NO \
@@ -176,13 +174,3 @@ src_install() {
prepgamesdirs
}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if use demo && ! has_version "games-fps/quake2-demodata[symlink]" ; then
- ewarn "To play the Quake 2 demo,"
- ewarn "emerge games-fps/quake2-demodata with the 'symlink' USE flag."
- echo
- fi
-}