summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch11
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch
new file mode 100644
index 000000000000..18ed8d65e0f9
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch
@@ -0,0 +1,11 @@
+--- a/libmultipath/structs.h
++++ b/libmultipath/structs.h
+@@ -106,7 +106,7 @@ enum yes_no_undef_states {
+ * _FIND_MULTIPATHS_F must have the same value as YNU_YES.
+ * Generate a compile time error if that isn't the case.
+ */
+-char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
++extern char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
+
+ #define find_multipaths_on(conf) \
+ (!!((conf)->find_multipaths & _FIND_MULTIPATHS_F))
diff --git a/sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild b/sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild
index feb9ba35c845..718daba1fda5 100644
--- a/sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild
+++ b/sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.7.5-respect-flags.patch
"${FILESDIR}"/${PN}-0.8.3-no-gziped-docs.patch
"${FILESDIR}"/${PN}-0.8.3-json-c-0.14.patch
+ "${FILESDIR}"/${PN}-0.8.3-fix-gcc-10-compatibility.patch
)
get_systemd_pv() {