summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-28.0.0.137.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index b0e450fca1e4..d525946c4260 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-28.0.0.126-npapi.i386.tar.gz 8510309 BLAKE2B 383e35d60cb0ff7c4a
DIST adobe-flash-28.0.0.126-npapi.x86_64.tar.gz 9027151 BLAKE2B 3f1371bf3ffbdf834a51cd7e00df387832fda565deed9cf3c46276e626c727d1fa66b4ab691c1e78b441842fc22adb6e2a84f5df2d928a3856a6e36a621e95ab SHA512 f8916cd3afa17536e3657232971b6363829b0434472884a8bef000c8ed64daa61fa0d6562eca34d6280c5dd3113e1713f5911d96d8d4bb2234855527a0145357
DIST adobe-flash-28.0.0.126-ppapi.i386.tar.gz 8546535 BLAKE2B ff4e27158c3af0107c14f2c22299fc15572d88d2a4660b6905594e4cb00d70fa5c7e24b77ebe43553195b79db94df1232a58faa3d284576fa16355c555b30386 SHA512 aa8a5ccc53dfaa737f8dd0250f26484298cd5cb05dfa45db5fde2788534b5aa5e6d3e2a96dfc0f4ce38e7cc8b28ed16d9d3bea9176cfb9df609878b99dbce8b1
DIST adobe-flash-28.0.0.126-ppapi.x86_64.tar.gz 9464135 BLAKE2B e0be3deb0454e0b0305993bc1922266d4ad0f3f10af69e955a2df76ee94f87173fcf590b9fbafb71fcd94968484bece3ce74219a72994ffedb36daf1be61f79d SHA512 9e7af54862a1dd5fa3ed059f5f64d44ae4c71b1c7d2104dc73b25d815b81e18db16b727810556f814b42e207fccdcc056044861b9ac48d59be5ff83b3e5183fa
+DIST adobe-flash-28.0.0.137-npapi.i386.tar.gz 8511300 BLAKE2B e1396927c13af726ec083402ec77f20ac40abe05ca868005f82156da0c3aef40651ccb3d1431f127e3cd4fa4669e809ef5e61a3989bea4597630c7197eae8e0d SHA512 37d5664096876adfe70d008277e0cb1bacf1264f8ca8270e4e775b17bcf7e032dcf5f4a0b13f77b6fd30184d07b3460698db48fd28a92f6820d702cab9891ae8
+DIST adobe-flash-28.0.0.137-npapi.x86_64.tar.gz 9027156 BLAKE2B 136f75ec96466c60895e38d8a4b36cab7f872d110459daac104d90384384c65ce05656ba01218d456917fd2fff2cb710a03b2374bd2d75c65a8e85cc37a24013 SHA512 07d0284296e4f6dbd8a7351da968cfdb4dff1885a997735b8e97f8c7a87c892241758cba376cd3b1ea059d26818111790fe1d3d665c4babaaeb7ae645a990a15
+DIST adobe-flash-28.0.0.137-ppapi.i386.tar.gz 8547088 BLAKE2B 8b5964935b752e26809e35b44d87ce613a951714019ca9d9902c64fa22f0cf057bd57ed57b5ce56c8b16e1ab859401425c21c85c06c123ba6f23f65bec46fc01 SHA512 f5d9d344c4f6522f35dbcefbd786f6dabd701346688f4858a9feb3b683cfa79342c0f5f62c08cb53870278f717a405803186bba49c1091f5a23fe86b9bcf43b1
+DIST adobe-flash-28.0.0.137-ppapi.x86_64.tar.gz 9463126 BLAKE2B 9fa28932aeaa4050282e202cb14adb83fc51d89ce1a36d5f7aa6b490069ad76827726ab0574580c351fe8f4ea755839c1549d94f4ffc3ca4663c3be9567eeb07 SHA512 9087b9197e0eeb8d71401246c7dd30bff9a571ce1bb07e30d99bda493b2da765a6929d13ec66a7e7ffb8614c58fcc2ed6556ed555c93adbeaa6e388e8d54e427
diff --git a/www-plugins/adobe-flash/adobe-flash-28.0.0.137.ebuild b/www-plugins/adobe-flash/adobe-flash-28.0.0.137.ebuild
new file mode 100644
index 000000000000..edde28781c17
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-28.0.0.137.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}