summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/XML-Compile/Manifest1
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.560.0.ebuild36
-rw-r--r--dev-perl/XML-Compile/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/Manifest b/dev-perl/XML-Compile/Manifest
index 91c7ba3d1078..e3787382201c 100644
--- a/dev-perl/XML-Compile/Manifest
+++ b/dev-perl/XML-Compile/Manifest
@@ -1 +1,2 @@
DIST XML-Compile-1.54.tar.gz 205002 SHA256 4c640da5b99494eb1375996413e2d0bb42f800836957a5c3de1ddf054c0ae4c2 SHA512 824318d0c941cd3e17f6c7396b815675f87fa03c5b17de6e2a71cfeefcffec8b2f050b1c6d63e013726a3d57cfc76c4ee29dbde14b91a6b1500341dd9c5e7310 WHIRLPOOL 9aad6bd92bc71185908f14f38a8ab604ce87376d7cbe0f55636a72b6191d02596ef00d49221ffb32cfcd03b715adcce32be8acc1861dbf8cd2aa4af4925edf64
+DIST XML-Compile-1.56.tar.gz 207239 SHA256 822ff1be69305408f0a427f10da2cc76535bdef593a527a6515d75bbc6cc5fbc SHA512 bd33651aba2270b7d2d61b4660ced63c8979f21d6852001cfbde24f192f52677c92b8fcce1597cc28da4d1791d5f609f8b77b5065d4860545543cdee6e138e9f WHIRLPOOL 8945c1258c7c4db05670c16bb42ab9f1c649978449a64248fb9cd55b5cb0db33ac188ec555d4184d527d5b64ebf77d527a2af36dd31b881ccd02e48faba51d3e
diff --git a/dev-perl/XML-Compile/XML-Compile-1.560.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.560.0.ebuild
new file mode 100644
index 000000000000..9bb1c935a3a8
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.560.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.56
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=dev-perl/Log-Report-1.30.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ dev-perl/Types-Serialiser
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-LibXML-2.10.700
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}
diff --git a/dev-perl/XML-Compile/metadata.xml b/dev-perl/XML-Compile/metadata.xml
index 01fc816dabd5..402e42a68029 100644
--- a/dev-perl/XML-Compile/metadata.xml
+++ b/dev-perl/XML-Compile/metadata.xml
@@ -8,5 +8,17 @@
<upstream>
<remote-id type="cpan">XML-Compile</remote-id>
<remote-id type="cpan-module">XML::Compile</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Iterator</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema::BuiltInFacets</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema::BuiltInTypes</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema::Instance</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema::NameSpaces</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Schema::Specs</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Translate</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Translate::Reader</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Translate::Template</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Translate::Writer</remote-id>
+ <remote-id type="cpan-module">XML::Compile::Util</remote-id>
</upstream>
</pkgmetadata>