summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-salt/Manifest1
-rw-r--r--dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-salt/Manifest b/dev-python/pytest-salt/Manifest
index e03d478fdd39..040d7f4ef999 100644
--- a/dev-python/pytest-salt/Manifest
+++ b/dev-python/pytest-salt/Manifest
@@ -1 +1,2 @@
+DIST pytest-salt-2019.2.1.post1.tar.gz 63824 BLAKE2B 684e1dee6df8f7459bfa1747ea017973d72bc69b87d22c65509ecada47469a94ce410034004a5df1396d5ed05557ddec90e34cb18792235babb5e0cf6d72d776 SHA512 7b9939c3bd1cbcb6d6d0b086c39e02deadd8b3c6fcc359924af7fa5afc2e443b927269b82aa5575413e4e6bbc052f4035fb17ab68dac59ea309320c0a647d36d
DIST pytest-salt-2020.1.27.tar.gz 64141 BLAKE2B 2b9261af2de28f8dce1abcd71b586594075916c8a5dbb27a24f15b9d95a575624be118d1c742f02020d3b968ffa4654cf6cd0dabefffe6876b87a4d1d58c3d60 SHA512 b0632e21f1ea5c3b57eb681cd8b270721cafd270321b708fca65427fc89817ed9e9a4216a520f35988c6866b1ed76ed84838009da9052a11cf8782d4dcf118ba
diff --git a/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild b/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild
new file mode 100644
index 000000000000..baf5647849f0
--- /dev/null
+++ b/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+MY_PV="${PV/_p/.post}"
+inherit distutils-r1
+
+DESCRIPTION="PyTest Salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"