summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild6
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
index 91f1f29db53c..c3e0840ad0b1 100644
--- a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils multilib
DESCRIPTION="Suffix-sorting library (for BWT)"
@@ -15,6 +15,8 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
src_prepare() {
+ cmake-utils_src_prepare
+
# will appreciate saner approach, if there is any
sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
*/CMakeLists.txt || die
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
index 53e5951a1206..142c77a7d431 100644
--- a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
+++ b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils multilib
#if LIVE
@@ -25,6 +25,8 @@ SRC_URI=
#endif
src_prepare() {
+ cmake-utils_src_prepare
+
# will appreciate saner approach, if there is any
sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
*/CMakeLists.txt || die