summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/cpop/cpop-0.0.4-r2.ebuild (renamed from net-im/cpop/cpop-0.0.4-r1.ebuild)20
-rw-r--r--net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch19
2 files changed, 35 insertions, 4 deletions
diff --git a/net-im/cpop/cpop-0.0.4-r1.ebuild b/net-im/cpop/cpop-0.0.4-r2.ebuild
index 9315a2381ea0..77c21027edcc 100644
--- a/net-im/cpop/cpop-0.0.4-r1.ebuild
+++ b/net-im/cpop/cpop-0.0.4-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol"
HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
@@ -11,14 +13,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND="dev-libs/glib:2
- x11-libs/gtk+:2"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+ "${FILESDIR}"/${P}-implicit-func-decls.patch
)
+src_prepare() {
+ default
+
+ # Clang 16, bug #900072
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install
dodoc README
diff --git a/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch b/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch
new file mode 100644
index 000000000000..ff3977e18055
--- /dev/null
+++ b/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/885705
+--- a/pop_client.c
++++ b/pop_client.c
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
++#include <unistd.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+--- a/pop_common.h
++++ b/pop_common.h
+@@ -3,4 +3,5 @@
+ #define CP_MSGSIZE 2048
+ #define CP_PORT 3233
+ void errquit(char *message);
++void printquit(char *message);
+ #endif