summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/xboxdrv/Manifest1
-rw-r--r--games-util/xboxdrv/metadata.xml4
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190116.ebuild74
3 files changed, 79 insertions, 0 deletions
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index 77d645902231..a08c71162940 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -1 +1,2 @@
+DIST xboxdrv-0.8.8_p20190116.tar.gz 322469 BLAKE2B 8827cafb98235f7ad9d83204c808eb6bc25fdfd48321050ab79b561fc6a1a3b628e4bd667f7f1be511420514ef7906efc803db4f50130c393d7fa3cb498fed26 SHA512 3f9f8346a5a8486fb9f1af3e27a947e37c73ceab8f433639adf890144844f4fb6d005da3c4c6c1abf0a1550b71aba8b89001f58965d67fdc21e5f41e50a21436
DIST xboxdrv-linux-0.8.8.tar.bz2 267919 BLAKE2B b6f09fc929ba561f0c18a777ca94f6972f366d29709d5fdcb168988311ca53eb813761df0f87d148795aa14d2d89b200e8123502c0b255ebe20e5f9caa18f8f1 SHA512 2978b33d23636431ee0cc393ea32d3d26ebe9f2b914f0bf8bc0e096f98202726768142e653bc5765ac55084b105ff3a6214bdf6e745fdd8aa167260c54c10494
diff --git a/games-util/xboxdrv/metadata.xml b/games-util/xboxdrv/metadata.xml
index 9a8e14a39d4a..fe838d30a8ff 100644
--- a/games-util/xboxdrv/metadata.xml
+++ b/games-util/xboxdrv/metadata.xml
@@ -9,4 +9,8 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">chewi/xboxdrv</remote-id>
+ <remote-id type="gitlab">xboxdrv/xboxdrv</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190116.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190116.ebuild
new file mode 100644
index 000000000000..228c7cc35069
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190116.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
+
+COMMIT="0c0143b59b0fd9718af4968992c96b6b6b2a2557"
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="https://xboxdrv.gitlab.io"
+SRC_URI="https://github.com/chewi/xboxdrv/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libudev:=
+ virtual/libusb:1
+ x11-libs/libX11
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+src_prepare() {
+ default
+
+ # Make it clearer that this is a patched fork.
+ echo -n "${PV%_*}.${PV#*_p}-gentoo" > VERSION || die
+}
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xboxdrv
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README.md TODO
+
+ newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
+ newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
+
+ insinto /etc/dbus-1/system.d
+ doins "${FILESDIR}"/org.seul.Xboxdrv.conf
+
+ udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
+ systemd_dounit "${FILESDIR}"/xboxdrv.service
+}
+
+pkg_postinst() {
+ udev_reload
+}