summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.6.1.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index b995ca505a0d..e4da7c2921ba 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -3,3 +3,4 @@ DIST harfbuzz-1.4.6.tar.bz2 1475086 SHA256 21a78b81cd20cbffdb04b59ac7edfb410e421
DIST harfbuzz-1.4.8.tar.bz2 1587622 SHA256 ccec4930ff0bb2d0c40aee203075447954b64a8c2695202413cc5e428c907131 SHA512 056a2c02f803439b39086e3ea988e424f5512b3213844f9008c62f5448a8ccdba525f532e7ed54641820a4ef6dc5bc4d13d4f7bfb39ff904f5939c855d294152 WHIRLPOOL c5b17719b0a362d775cbebf081bb6bd946c3a3401a7ed292ae0bc021abe2b4a18a5fab3adc8e65793ead45d665b2b45b04ffaf8ea2924c4325b6fd39d1b1abf6
DIST harfbuzz-1.5.1.tar.bz2 1615704 SHA256 56838dfdad2729b8866763c82d623354d138a4d99d9ffb710c7d377b5cfc7c51 SHA512 e5235c9fe4524059128f97e2773056533803b40db70c18b43c8dc6e27a970efc40d9ce6e8754ae7075c245cf8f4386b33e922a6edb3b6a722a596cb7759b8b36 WHIRLPOOL 8cf092ffcf42b5744041b3e2d40ce720a2a089964bb5d8d6a3ed5ccb846df8f3f44e6182744cb7b8c132e2fbfcc93c13fd974c2faa0adcf66961fc3b9863563d
DIST harfbuzz-1.6.0.tar.bz2 1625615 SHA256 5037ac0efc85a02a334965e66c1053d9dc9ed6833eae9739bd85bc33c83167c9 SHA512 392c7055d7fe9bc3fea07e62fa9d00407c98d502de7b42937f434c6127f660521706d3b2c0afbc61ad636676abb50bafe73afb15b9090f0fe1f75443f1f34706 WHIRLPOOL 55b0c66500cfe099a5b1658fe89e5e44665158f86c82851c0787a417d6bf4d914c31fc2324b4816d7ed948e220a9cd0eea6dc0dcdb87c217dfe4f28c52105ac3
+DIST harfbuzz-1.6.1.tar.bz2 1638550 SHA256 31d33cdb22f3b6623665bfcd263efc897cce1af44dba5f8e2f6fdcf823ae1129 SHA512 c4235fa2b27914dd4b2093c3c568d173f1e6bd16af23ab96350b3e74132eccaf18f6fa391b0f749f73344931a8f9af7f0e5271db9d7c9565bd98be366867f7dc WHIRLPOOL bf508e3ca9db4d1f4cca218a2f0d6bce7a002123d429a69ef1e504c01274d69f7214819e57496eddfbb6f35facc3cd9eb8af0a0910c877f2c9bd3036b5be6dba
diff --git a/media-libs/harfbuzz/harfbuzz-1.6.1.ebuild b/media-libs/harfbuzz/harfbuzz-1.6.1.ebuild
new file mode 100644
index 000000000000..da388e5fba70
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.6.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with fontconfig) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}