summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/simon/metadata.xml2
-rw-r--r--app-accessibility/simon/simon-0.4.1.ebuild8
-rw-r--r--app-office/calligra/calligra-2.9.11.ebuild10
-rw-r--r--app-office/calligra/metadata.xml2
-rw-r--r--kde-base/plasma-workspace/metadata.xml2
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.11.22.ebuild11
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-4.14.3-r1.ebuild6
-rw-r--r--kde-plasma/kdeplasma-addons/metadata.xml2
-rw-r--r--kde-plasma/libplasmaclock/libplasmaclock-4.11.22.ebuild6
-rw-r--r--kde-plasma/libplasmaclock/metadata.xml2
10 files changed, 25 insertions, 26 deletions
diff --git a/app-accessibility/simon/metadata.xml b/app-accessibility/simon/metadata.xml
index a2a7c41032bc..77c20c8190ae 100644
--- a/app-accessibility/simon/metadata.xml
+++ b/app-accessibility/simon/metadata.xml
@@ -6,8 +6,8 @@
<name>Gentoo Accessibility Project</name>
</maintainer>
<use>
- <flag name="kdepim">Use <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="opencv">Use <pkg>media-libs/opencv</pkg></flag>
+ <flag name="pim">Use <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="sphinx">Build sphinx backend (pulls <pkg>app-accessibility/julius</pkg> if disabled</flag>
</use>
</pkgmetadata>
diff --git a/app-accessibility/simon/simon-0.4.1.ebuild b/app-accessibility/simon/simon-0.4.1.ebuild
index 3f44351181db..d4352ac11200 100644
--- a/app-accessibility/simon/simon-0.4.1.ebuild
+++ b/app-accessibility/simon/simon-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -19,7 +19,7 @@ SRC_URI="mirror://kde/stable/simon/${PV}/src/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="kdepim libsamplerate nls opencv sphinx"
+IUSE="libsamplerate nls opencv pim sphinx"
RDEPEND="
dev-qt/qtcore:4
@@ -32,13 +32,13 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXtst
x11-libs/qwt:6
- kdepim? ( kde-apps/kdepimlibs:4 )
libsamplerate? ( media-libs/libsamplerate )
nls? (
kde-apps/kde4-l10n
virtual/libintl
)
opencv? ( media-libs/opencv )
+ pim? ( kde-apps/kdepimlibs:4 )
sphinx? (
>=app-accessibility/pocketsphinx-0.8
>=app-accessibility/sphinxbase-0.8
@@ -64,7 +64,7 @@ src_configure() {
-DBackendType=$(usex sphinx "both" "jhtk")
$(cmake-utils_use_with sphinx Sphinxbase)
$(cmake-utils_use_with sphinx Pocketsphinx)
- $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with pim KdepimLibs)
$(cmake-utils_use_with libsamplerate LibSampleRate)
$(cmake-utils_use_with opencv OpenCV)
$(cmake-utils_use_enable nls NLS)
diff --git a/app-office/calligra/calligra-2.9.11.ebuild b/app-office/calligra/calligra-2.9.11.ebuild
index da995b52d515..f0deaf92c170 100644
--- a/app-office/calligra/calligra-2.9.11.ebuild
+++ b/app-office/calligra/calligra-2.9.11.ebuild
@@ -41,8 +41,8 @@ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
fi
IUSE="attica color-management +crypt +eigen +exif fftw +fontconfig freetds
-+glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw +kdepim +lcms
-marble mysql +okular openexr +pdf postgres spacenav sybase test tiff +threads
++glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw +lcms marble mysql
++okular openexr +pdf +pim postgres spacenav sybase test tiff +threads
+truetype vc xbase +xml"
# Don't use Active, it's broken on desktops.
@@ -56,7 +56,7 @@ REQUIRED_USE="
calligra_features_author? ( calligra_features_words )
calligra_features_gemini? ( opengl )
calligra_features_krita? ( eigen exif lcms opengl )
- calligra_features_plan? ( kdepim )
+ calligra_features_plan? ( pim )
calligra_features_sheets? ( eigen )
calligra_features_stage? ( webkit )
vc? ( calligra_features_krita )
@@ -93,7 +93,6 @@ RDEPEND="
jpeg? ( virtual/jpeg:0 )
jpeg2k? ( media-libs/openjpeg:0 )
kdcraw? ( $(add_kdeapps_dep libkdcraw) )
- kdepim? ( $(add_kdeapps_dep kdepimlibs) )
lcms? (
media-libs/lcms:2
x11-libs/libX11
@@ -110,6 +109,7 @@ RDEPEND="
app-text/poppler:=
media-gfx/pstoedit
)
+ pim? ( $(add_kdeapps_dep kdepimlibs) )
postgres? (
dev-db/postgresql:*
dev-libs/libpqxx
@@ -206,7 +206,6 @@ src_configure() {
$(cmake-utils_use_with jpeg JPEG)
$(cmake-utils_use_with jpeg2k OpenJPEG)
$(cmake-utils_use_with kdcraw Kdcraw)
- $(cmake-utils_use_with kdepim KdepimLibs)
$(cmake-utils_use_with lcms LCMS2)
$(cmake-utils_use_with marble CalligraMarble)
$(cmake-utils_use_with mysql MySQL)
@@ -215,6 +214,7 @@ src_configure() {
$(cmake-utils_use opengl USEOPENGL)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with pdf Pstoedit)
+ $(cmake-utils_use_with pim KdepimLibs)
$(cmake-utils_use_with postgres CalligraPostgreSQL)
$(cmake-utils_use_build postgres pqxx)
$(cmake-utils_use_with spacenav Spnav)
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index 55157ac651a6..70bc199269da 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -18,9 +18,9 @@
<flag name="gsf">Enable support for ODT structures extraction via <pkg>gnome-extra/libgsf</pkg></flag>
<flag name="import-filter">Enable support for various import filter file formats like WordPerfect, Visio and Apple Keynote</flag>
<flag name="kdcraw">Enable support for KDE image manipulating interface via <pkg>kde-apps/libkdcraw</pkg></flag>
- <flag name="kdepim">Enable support for KDEPIM resources integration</flag>
<flag name="marble">Enable displaying of maps using Marble</flag>
<flag name="okular">Enable bindings for <pkg>kde-apps/okular</pkg></flag>
+ <flag name="pim">Enable support for KDE PIM resources integration</flag>
<flag name="spacenav">Enable support for the 3Dconnexion spacenav input device via <pkg>dev-libs/libspnav</pkg></flag>
<flag name="vc">Enable support for <pkg>dev-libs/vc</pkg>, could be a significant speed boost on krita</flag>
<flag name="xbase">Enable support for xbase compatible database formats</flag>
diff --git a/kde-base/plasma-workspace/metadata.xml b/kde-base/plasma-workspace/metadata.xml
index 14a6d630dcae..a103038bf8b9 100644
--- a/kde-base/plasma-workspace/metadata.xml
+++ b/kde-base/plasma-workspace/metadata.xml
@@ -6,8 +6,8 @@
<name>Gentoo KDE Project</name>
</maintainer>
<use>
- <flag name="kdepim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="json">Enable JSON support via <pkg>dev-libs/qjson</pkg></flag>
+ <flag name="pim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
</use>
</pkgmetadata>
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.11.22.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.11.22.ebuild
index 21333767b946..3ab79400804b 100644
--- a/kde-base/plasma-workspace/plasma-workspace-4.11.22.ebuild
+++ b/kde-base/plasma-workspace/plasma-workspace-4.11.22.ebuild
@@ -15,19 +15,18 @@ inherit python-single-r1 kde4-meta
DESCRIPTION="Plasma: KDE desktop framework"
KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps json +kdepim python qalculate"
+IUSE="debug gps json +pim python qalculate"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
COMMONDEPEND="
dev-libs/libdbusmenu-qt
>=dev-qt/qtcore-4.8.4-r3:4
- !kde-misc/ktouchpadenabler
$(add_kdebase_dep kactivities)
kde-plasma/kephal:4
kde-plasma/ksysguard:4
kde-plasma/libkworkspace:4
- kde-plasma/libplasmaclock:4[kdepim?]
+ kde-plasma/libplasmaclock:4[pim?]
kde-plasma/libplasmagenericshell:4
kde-plasma/libtaskmanager:4
x11-libs/libX11
@@ -39,7 +38,7 @@ COMMONDEPEND="
x11-libs/libXrender
gps? ( >=sci-geosciences/gpsd-2.37 )
json? ( dev-libs/qjson )
- kdepim? ( $(add_kdeapps_dep kdepimlibs) )
+ pim? ( $(add_kdeapps_dep kdepimlibs) )
python? (
${PYTHON_DEPS}
>=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
@@ -100,8 +99,8 @@ src_configure() {
-DWITH_Xmms=OFF
$(cmake-utils_use_with gps libgps)
$(cmake-utils_use_with json QJSON)
- $(cmake-utils_use_with kdepim Akonadi)
- $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with pim Akonadi)
+ $(cmake-utils_use_with pim KdepimLibs)
$(cmake-utils_use_with python PythonLibrary)
$(cmake-utils_use_with qalculate)
)
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-4.14.3-r1.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-4.14.3-r1.ebuild
index d90ebf7163ac..b4b5534f6440 100644
--- a/kde-plasma/kdeplasma-addons/kdeplasma-addons-4.14.3-r1.ebuild
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-4.14.3-r1.ebuild
@@ -10,7 +10,7 @@ inherit flag-o-matic kde4-base
DESCRIPTION="Extra Plasma applets and engines"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="attica debug desktopglobe eigen exif fcitx ibus json +kdepim oauth
+IUSE="attica debug desktopglobe eigen exif fcitx ibus json oauth +pim
qalculate qwt scim"
RESTRICT=test
@@ -28,8 +28,8 @@ COMMON_DEPEND="
fcitx? ( app-i18n/fcitx[dbus(+)] )
ibus? ( app-i18n/ibus )
json? ( dev-libs/qjson )
- kdepim? ( $(add_kdeapps_dep kdepimlibs) )
oauth? ( dev-libs/qoauth:0 )
+ pim? ( $(add_kdeapps_dep kdepimlibs) )
qalculate? ( sci-libs/libqalculate )
qwt? ( x11-libs/qwt:5 )
scim? ( app-i18n/scim )
@@ -51,8 +51,8 @@ src_configure() {
$(cmake-utils_use_with exif Kexiv2)
$(cmake-utils_use_build ibus)
$(cmake-utils_use_with json QJSON)
- $(cmake-utils_use_with kdepim KdepimLibs)
$(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with pim KdepimLibs)
$(cmake-utils_use_with qalculate)
$(cmake-utils_use_with qwt)
$(cmake-utils_use_build scim)
diff --git a/kde-plasma/kdeplasma-addons/metadata.xml b/kde-plasma/kdeplasma-addons/metadata.xml
index 3c65517d074e..8235b96ac13b 100644
--- a/kde-plasma/kdeplasma-addons/metadata.xml
+++ b/kde-plasma/kdeplasma-addons/metadata.xml
@@ -12,8 +12,8 @@
<flag name="eigen">Build Mandelbrot wallpaper plugin using <pkg>dev-cpp/eigen</pkg> using SLOT 2</flag>
<flag name="fcitx">Use fcitx input method via <pkg>app-i18n/fcitx</pkg></flag>
<flag name="json">Enable JSON support via <pkg>dev-libs/qjson</pkg></flag>
- <flag name="kdepim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="oauth">Enable OAuth support via <pkg>dev-libs/qoauth</pkg></flag>
+ <flag name="pim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
<flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
<flag name="qwt">Enable applets that use <pkg>x11-libs/qwt</pkg> SLOT 5</flag>
<flag name="scim">Enable applets that use <pkg>app-i18n/scim</pkg></flag>
diff --git a/kde-plasma/libplasmaclock/libplasmaclock-4.11.22.ebuild b/kde-plasma/libplasmaclock/libplasmaclock-4.11.22.ebuild
index a46230fc7603..fb1a94f28a09 100644
--- a/kde-plasma/libplasmaclock/libplasmaclock-4.11.22.ebuild
+++ b/kde-plasma/libplasmaclock/libplasmaclock-4.11.22.ebuild
@@ -10,11 +10,11 @@ inherit kde4-meta
DESCRIPTION="Libraries for KDE Plasma's clocks"
KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="debug +kdepim"
+IUSE="debug +pim"
DEPEND="
kde-plasma/kephal:4
- kdepim? ( $(add_kdeapps_dep kdepimlibs) )
+ pim? ( $(add_kdeapps_dep kdepimlibs) )
"
RDEPEND="${DEPEND}"
@@ -26,7 +26,7 @@ KMEXTRACTONLY="
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with pim KdepimLibs)
)
kde4-meta_src_configure
diff --git a/kde-plasma/libplasmaclock/metadata.xml b/kde-plasma/libplasmaclock/metadata.xml
index 41cb6573fe6b..08e568cb6141 100644
--- a/kde-plasma/libplasmaclock/metadata.xml
+++ b/kde-plasma/libplasmaclock/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo KDE Project</name>
</maintainer>
<use>
- <flag name="kdepim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
+ <flag name="pim">KDE PIM integration via <pkg>kde-apps/kdepimlibs</pkg></flag>
</use>
</pkgmetadata>