summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/liboglappth/files/gcc-4.3.patch10
-rw-r--r--x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild (renamed from x11-libs/liboglappth/liboglappth-1.0.0.ebuild)20
2 files changed, 20 insertions, 10 deletions
diff --git a/x11-libs/liboglappth/files/gcc-4.3.patch b/x11-libs/liboglappth/files/gcc-4.3.patch
index bc04b9e97c7b..cf45065916bc 100644
--- a/x11-libs/liboglappth/files/gcc-4.3.patch
+++ b/x11-libs/liboglappth/files/gcc-4.3.patch
@@ -1,10 +1,10 @@
---- a/src/base_wcl.cpp 2008-07-07 23:49:10.000000000 -0700
-+++ b/src/base_wcl.cpp 2008-07-07 23:49:26.000000000 -0700
-@@ -11,6 +11,7 @@
+--- a/src/base_wcl.cpp
++++ b/src/base_wcl.cpp
+@@ -22,6 +22,7 @@
#include "base_app.h"
#include <stdlib.h> // the definition for NULL...
+#include <cstring>
- #include <GL/glut.h>
-
+ #include <GL/gl.h>
+ #include <GL/glu.h>
diff --git a/x11-libs/liboglappth/liboglappth-1.0.0.ebuild b/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
index c0b2725651a1..eb68dba4208b 100644
--- a/x11-libs/liboglappth/liboglappth-1.0.0.ebuild
+++ b/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Libary for OpenGL applications with easy-to-code scene setup and selection"
HOMEPAGE="http://www.bioinformatics.org/ghemical/"
@@ -10,12 +10,22 @@ SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="
virtual/opengl
media-libs/freeglut"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/gcc-4.3.patch )
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}