summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/adwaita-icon-theme-legacy/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme-legacy/adwaita-icon-theme-legacy-46.2.ebuild40
-rw-r--r--x11-themes/adwaita-icon-theme-legacy/metadata.xml12
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild5
4 files changed, 57 insertions, 1 deletions
diff --git a/x11-themes/adwaita-icon-theme-legacy/Manifest b/x11-themes/adwaita-icon-theme-legacy/Manifest
new file mode 100644
index 000000000000..6e5081ef80a1
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme-legacy/Manifest
@@ -0,0 +1 @@
+DIST adwaita-icon-theme-legacy-46.2.tar.xz 2056840 BLAKE2B 571ad9402c3ab3d29d856b72fae3969bc78fc4ca40aa285d84d9ec562084182dacf566820deca13ed028d92b88e80f7410824b605bf89a6501c39370bce54a12 SHA512 01e4711e353d44914ed69a5d815046260c360f6da5586e419f54b33e9661abbb90bc8b675a505107e713d5b872d0d464491589498f40bad00f03183ddd81e791
diff --git a/x11-themes/adwaita-icon-theme-legacy/adwaita-icon-theme-legacy-46.2.ebuild b/x11-themes/adwaita-icon-theme-legacy/adwaita-icon-theme-legacy-46.2.ebuild
new file mode 100644
index 000000000000..fe962b1455a2
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme-legacy/adwaita-icon-theme-legacy-46.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="Adwaita Icon Theme legacy"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/adwaita-icon-theme-legacy"
+
+LICENSE="LGPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via
+# its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+"
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_test() {
+ :; # No tests
+}
+
+src_install() {
+ meson_src_install
+ # https://gitlab.gnome.org/GNOME/adwaita-icon-theme-legacy/-/issues/3
+ mv "${D}"/usr/share/licenses/adwaita-icon-theme \
+ "${D}"/usr/share/licenses/adwaita-icon-theme-legacy || die
+}
diff --git a/x11-themes/adwaita-icon-theme-legacy/metadata.xml b/x11-themes/adwaita-icon-theme-legacy/metadata.xml
new file mode 100644
index 000000000000..a75ff63cf314
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme-legacy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/adwaita-icon-theme-legacy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild
index 5e55fddf6253..4f1301c6cde9 100644
--- a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-46.2.ebuild
@@ -24,7 +24,10 @@ IUSE="branding"
# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via
# its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
# adwaita-icon-theme-legacy needed to be FDO compatible (as done in other distributions
-# as Fedora, https://bugs.gentoo.org/927897)
+# as Fedora:
+# https://bugs.gentoo.org/927897
+# https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/issues/288
+# https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/commit/9cb8144b387251eef9c0a221b2febe18802e2435
DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
RDEPEND="${DEPEND}
>=gnome-base/librsvg-2.48:2