summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/puppet-lint/Manifest1
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.5.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index 659106e3c545..de83b3353c63 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -1 +1,2 @@
DIST puppet-lint-2.4.2.gem 93184 BLAKE2B 5170bd9c30f6e2f5b30120b6edc74550e697c3243d2f5c7249f27a2d61ca2f5612d96efdc0f6be8d065e7d7a4460b9cf6e6dad13a5b24c4ce100d4e6df2f0425 SHA512 ee846688b13536b7d146ea50c0efe5083babf1ca09b77182437ec93be754ae076d54ac34f8082867a26b6df12a09bcd316e5b1aaa9c98150f9411a0c8b007c71
+DIST puppet-lint-2.5.0.gem 90112 BLAKE2B c731e0988f09f779c50aad118f136f79c6e042f43cc8a5163967c44a72d4019a00426578bc95b4cf9618057027c1707cd3463ea408a30d25ca0a0911dc3c94eb SHA512 b04097443eae40a084475f95c57ebde73af937ca3b9b006237c6b5e60caf939338e09cb1e259a26524d2294ecbc61bd91b6e34f7051d87211078912518cb364b
diff --git a/app-admin/puppet-lint/puppet-lint-2.5.0.ebuild b/app-admin/puppet-lint/puppet-lint-2.5.0.ebuild
new file mode 100644
index 000000000000..9418b0418b4a
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"