summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/lilypond/files/lilypond-9999-programming_error.patch13
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/media-sound/lilypond/files/lilypond-9999-programming_error.patch b/media-sound/lilypond/files/lilypond-9999-programming_error.patch
new file mode 100644
index 000000000000..f2b85164a6e5
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-9999-programming_error.patch
@@ -0,0 +1,13 @@
+diff --git a/lily/general-scheme.cc b/lily/general-scheme.cc
+index d25e6c9ef8..2fd2e4a4fa 100644
+--- a/lily/general-scheme.cc
++++ b/lily/general-scheme.cc
+@@ -275,7 +275,7 @@ LY_DEFINE (ly_protects, "ly:protects",
+ #if SCM_MAJOR_VERSION < 2 || SCM_MAJOR_VERSION == 2 && SCM_MINOR_VERSION < 1
+ return scm_protects;
+ #else
+- return programming_error ("ly:protects is not supported in Guile 2.1");
++ programming_error ("ly:protects is not supported in Guile 2.1");
+ #endif
+ }
+
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 27bfc06997d6..e24a72ba576e 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -22,6 +22,7 @@ SLOT="0"
LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
IUSE="debug emacs guile2 profile vim-syntax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+PATCHES=(${FILESDIR}/$P-programming_error.patch)
RDEPEND=">=app-text/ghostscript-gpl-8.15
>=dev-scheme/guile-1.8.2:12[deprecated,regex]