summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/glfw/Manifest1
-rw-r--r--media-libs/glfw/glfw-3.3.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index 30dd003a8d33..f1af4ed2fe49 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1 +1,2 @@
DIST glfw-3.3.4.tar.gz 762885 BLAKE2B b88f80ec8cfb1607a8c5ce5e6eabfe5c9813235c6225629ef8001ba5f46cdbed1d726aeed170a8749bbd048f1517cb614f9fc5ad7604ae1698b83b5e995b8cd6 SHA512 2b45ab72da7a2c007c0f42ccd56205f9684cfb980e2b1df127850cd057bb2b02ce02c7c64acd54cd433778e7017148f214afedf09badff9d2edf5f9b8d9d2701
+DIST glfw-3.3.5.tar.gz 776593 BLAKE2B ce92a42ef7361ae2580c9d6722d340106f9ca26e7fb436b9a4be2f25bf4a15d2b08d82ff71ad4ce4cd6a59e31d934d0fe6ab0e546474a3e7de38e229795ee0e8 SHA512 cbb8ebf25d3d826eb1daeff3ad2e0e965ce9def3352955f297743d918f625d96bc05bf87c90f7b57ec53376a0f2f6ce62f80b57fac4e81e023400de275e97beb
diff --git a/media-libs/glfw/glfw-3.3.5.ebuild b/media-libs/glfw/glfw-3.3.5.ebuild
new file mode 100644
index 000000000000..c82e318544e2
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="wayland-only"
+
+RDEPEND="
+ media-libs/libglvnd[${MULTILIB_USEDEP}]
+ wayland-only? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+ !wayland-only? (
+ media-libs/libglvnd[X]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ )"
+DEPEND="
+ ${RDEPEND}
+ wayland-only? (
+ dev-libs/wayland-protocols
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ )
+ !wayland-only? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXinerama[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ )"
+BDEPEND="
+ wayland-only? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND=$(usex wayland-only)
+ )
+
+ cmake-multilib_src_configure
+}