summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/subliminal/Manifest1
-rw-r--r--media-video/subliminal/subliminal-2.0.3.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index b2765faaf32e..f5bd191d03e9 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -1,3 +1,2 @@
DIST matroska_test_w1_1.zip 184550509 SHA256 d86f96e165e695e6cf5324ebca184f2df723872f02965b565820d265b53004eb SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f WHIRLPOOL 3d0a16871fc7df0a3ef3f34f7c496eff188400a9796a2ad66667112ef0de7deecf025196898bd24ea395f8c44e75156a8b8c09d40a92e98d833d995473eefa9e
-DIST subliminal-2.0.3.tar.gz 4428821 SHA256 12ad058d8bfdb0471d2021f8a486c2a11d2470e845bec1e71f698e4523ddc8fe SHA512 ed014ac25ab867cf1d7d16c1ecc19364a1b1281893c3e1aa1e678176d6df12623fc29f6a8159984cd2d621bf2f708655382ae7e0cf41c92956fc2d803f1b5c37 WHIRLPOOL 39a20b595660a78c3a48efa7affc973e4349f2912b5d077583d75d05e4bad8675b5d5594512e739398fff641fdc76a08afdc1deec6f54bba5b02b3f5014ea531
DIST subliminal-2.0.5-r1.tar.gz 4442435 SHA256 b7a54377937810842cf9e9f06d9c9affd1e02c591f3f9a1ddf76c25a9b51a434 SHA512 b0f99c6b2fa6bc3860c86592bb428c7b4b34836df7a619b19d69b15532a68b4d05369f724131e120d4b390bd91f430aea442aef72ebc00ae8e3d31a457925eec WHIRLPOOL eae38af4612576fa6903ab23aeab6d1c769ee1c3a95709c23e265819159d83e0624c53527cf86d58e059aca51f2ba7f27820e413ac9dcb584c58d0066a38067a
diff --git a/media-video/subliminal/subliminal-2.0.3.ebuild b/media-video/subliminal/subliminal-2.0.3.ebuild
deleted file mode 100644
index 7caabb45d9c1..000000000000
--- a/media-video/subliminal/subliminal-2.0.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to search and download subtitles"
-HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.python.org/pypi/subliminal"
-SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.4.0:4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- >=dev-python/click-4.0[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
- >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
- >=dev-python/pytz-2012c[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- )
-"
-
-# Tests require network.
-RESTRICT=test
-
-python_prepare_all() {
- # Disable code checkers as they require unavailable dependencies.
- sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
- sed -i -e "s/'pytest-\(pep8\|flakes\)',//g" setup.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}