summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/diff-cover/Manifest1
-rw-r--r--dev-util/diff-cover/diff-cover-6.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/diff-cover/Manifest b/dev-util/diff-cover/Manifest
index 6ef4b403750b..b8d442e54325 100644
--- a/dev-util/diff-cover/Manifest
+++ b/dev-util/diff-cover/Manifest
@@ -1 +1,2 @@
DIST diff-cover-5.0.1.tar.gz 84135 BLAKE2B 6a246df971e76155864d8b4ba11cbecd0e3f6b2f97edbb458f410e89e1748e91053fccd03bd4b73e8a5704d70169c3183f61e04326d391b01663fe446b2dd365 SHA512 d21fe75695b635222c3d9b053aacfcd22792ad9db87a6bbc0cc72491183c96e144b34edb75c97b7625d05bdbafb2ce7e2e66f0b65f3502cba801d11c23efc7e8
+DIST diff-cover-6.5.0.tar.gz 108392 BLAKE2B fc3a2a46e66501da5c08ce58fc13e46671246737320a0b6350b78f6b777d3759ec47d4ada170bb3dffcfe0927920741a3c5bff03509d92b2cc873cecce282eb1 SHA512 a00a1009fc8b9ca46f93573e3a2d6eb6a6a29f0e61891c839209dbe3d208d873a42524b30e3a18918817d173cefc3c5f481f7eea689170d72b5cd08857a8f021
diff --git a/dev-util/diff-cover/diff-cover-6.5.0.ebuild b/dev-util/diff-cover/diff-cover-6.5.0.ebuild
new file mode 100644
index 000000000000..9a3fea81c28c
--- /dev/null
+++ b/dev-util/diff-cover/diff-cover-6.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{7..11} )
+inherit distutils-r1
+
+DESCRIPTION="Find diff lines that do not have test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/diff-cover/diff_cover}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ dev-python/jinja2_pluralize[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest