summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/files/qtile.desktop6
-rw-r--r--x11-wm/qtile/qtile-0.21.0.ebuild69
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index a8500cbec56b..aac5206b1051 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,2 +1,3 @@
DIST qtile-0.16.1.tar.gz 324668 BLAKE2B 1f75f5dbcab6180dcf778e28108e70b6dd01105fa275aadf4a53d96ab84f3b759cb8553bcf3de2011b0990d61adc9269663afa32b83d1aa9c052b00ef9e89358 SHA512 aea42f7f6799a88b586167a57f5b5ab6f1c5bb663dec352d15eb47ce0d37fb23c31d1631cab8178c71be5ae714ec12c35a350377383dba1749a98cd45c22515b
DIST qtile-0.17.0.tar.gz 336235 BLAKE2B f2290ab823b31cd8ed512f076018a8df19bbfedbb7d5c6932eee7cd46c341a08af04ed0d99f4391d1b3ccc07eb33015bbf0050c1c5d749bace4fb6dcfcb71ac9 SHA512 bfe51aabef2d48693c5bb7525cf67b1bb99cf3af5a653cd81d523e5adaa4767a43e7a87db14f9b85fae3a9e414af41a2e66736556eb1552d099755ba6f39caeb
+DIST qtile-0.21.0.tar.gz 475428 BLAKE2B 8c63eb8776fb6feab30c7ee2a19e6f28df6715fc18b09c63b89de6bf2129cd3c5c516d0c9efc946f24590fa8afc6e87c704c8e3b7094d0843b5b6e34df57ca18 SHA512 b7c5fc478180413e263445316ac9560c1d22668194415c3e4edae5c672f4b317fd978083dc9a985f0d145aeaaa55ffab0017e83af963f30d8b36f9963e12b079
diff --git a/x11-wm/qtile/files/qtile.desktop b/x11-wm/qtile/files/qtile.desktop
new file mode 100644
index 000000000000..5b00f85a88c0
--- /dev/null
+++ b/x11-wm/qtile/files/qtile.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Qtile
+Comment=Qtile Wayland Session
+Exec=qtile start -b wayland
+Type=Application
+Keywords=wm;tiling
diff --git a/x11-wm/qtile/qtile-0.21.0.ebuild b/x11-wm/qtile/qtile-0.21.0.ebuild
new file mode 100644
index 000000000000..d219eaf9e16c
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.21.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.10.1[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango"
+BDEPEND="test? ( x11-base/xorg-server[xephyr] )"
+
+EPYTEST_DESELECT=(
+ # Can't find built qtile like migrate
+ test/test_qtile_cmd.py::test_qtile_cmd
+ test/test_qtile_cmd.py::test_display_kb
+)
+
+EPYTEST_IGNORE=(
+ # Tries to find binary and fails; not worth running anyway?
+ test/test_migrate.py
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Force usage of built module
+ rm -rf "${S}"/libqtile || die
+
+ epytest || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins "${FILESDIR}"/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}